[v2.2] Feature Proposal: Auto-speakerphone using Proximity Sensor

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: Synper311, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This was one of my favorite patches from webOS.

Basically, it was an option the user could enable that would use the Proximity Sensor to determine if the user's face was against the phone. If their face was there, the Call played through the Earpiece. 

If the user takes the phone away from their face and the Proximity Sensor can't detect them, it switches the call automatically to the Speakerphone.

This patch had two variants: instant, and a version with a delay.

The delay is useful as it allows the user to quickly look at the Callscreen to check battery, signal, call time, incoming calls, etc without having the playback source switch.

Please, consider this as a behavior as it is really pleasant to use.
(Reporter)

Updated

4 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
Redirecting to Carrie.
Flags: needinfo?(cawang)

Comment 2

4 years ago
Clearing the flag for UX, but Johan, this should also be flagged to Wilfred, who is the Comms PM. 

Generally speaking, though, I am not sure this is something we would consider, unless (like so many other things) it were a setting. I am often on the train, sidewalk, in a cafe, etc. and the fact that I've removed a phone from my face to pay a train fare or move to let someone else sit down does not mean that I want any output to be heard by speaker phone and disturb others (to say nothing of potential privacy intrusion).
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(wmathanaraj)
(Reporter)

Comment 3

4 years ago
Stephany,

I thought I was clear in my initial post that this was an optional thing and was intended as one. If not, I'm going to make that clear now: I envision this as an optional behavior the user can set from somewhere appropriate, likely the Call Settings Settings screen.

I'd like to see the option to enable/disable this behavior, and another field that would control the delay. I think the most appropriate thing for the delay field would be direct number entry so users could fine-tune the delay to suit their habits, but perhaps a numeric picker (like the one used for setting time in the Alarms app) could be used instead with some sane values (50ms,125ms,250ms,500ms,750ms, 1s, 1.5s, etc).

I should probably make it clear that the delay time refers only to the amount of time after reading No Proximity that the phone swiches FROM the earpiece to the speakerphone. The phone should ALWAYS switch INSTANTLY from Speaker back to earpiece on Proximity to prevent needlessly loud/unpleasant noises in the ear as well as preventing conversations being out in the open too long as Stephany notes above.

Stephany, I don't know about you but typically when I take my phone away from my face to accomplish another task, I either put it down on a surface or I put it in one of my pockets. In both of those instances the proximity sensor should still read that there is something close, thus keeping the call private. The only time it'd not see anything as close would be if you held it in your hand away from your body or anything else, which given the fact that you needed that hand free to accomplish a task, doesn't seem very likely. Alternatively, you put it on a surface face up away from yourself, which is a pretty easy thing to do (and how I prefer it when I need both hands to work while talking).

As someone who is almost always on the move and working with my hands, this feature makes life very, very easy for me as I accomplish my work and go about my daily routine. When I do my contract work, I'm oftentimes required to be on the phone with clients during the actual work. Being able to seamlessly use my hands for work or holding the phone without having to go "Wait, hold on a sec" as I hit the power button, turn on the display, unlock it, and toggle speakerphone on/off would be a godsend.

If this were an option, it'd harm no one and would, I believe, benefit many. I think you might even enjoy it if you got a chance to use it out. I can't emphasize enough how awesome this feature made using my webOS devices as a phone.
Leave it to Wilfred for backlog items. Thanks!
Flags: needinfo?(cawang)

Updated

4 years ago
Flags: needinfo?(wmathanaraj)

Comment 5

8 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.