Keyboard is overlapping SIM PIN dialog buttons with SHB enabled

VERIFIED FIXED in 2.2 S1 (5dec)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: gwagner, Assigned: mancas)

Tracking

unspecified
2.2 S1 (5dec)
x86
macOS

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Updated

5 years ago
blocking-b2g: --- → 2.2+
Whiteboard: [systemsfe]
(Reporter)

Updated

5 years ago
This issue occurs on both 2.2 Flame KK and 2.1 Flame KK and thus is not a regression as SHB before 2.1 is not considered valid to test.

Environmental Variables:
Device: Flame 2.2
BuildID: 20141125135735
Gaia: 0f7bb156969c5c838ff90ebc88d7691fc4d94310
Gecko: ced1402861b8
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20141125135229
Gaia: b711909aab9a5cb84cba45175b909ad7f7b63842
Gecko: 6da00aa9b3ff
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

5 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 2

5 years ago
Posted file Proposed patch
The problem is that every dialog inside the |dialog-overlay| element, are updating the element height when the keyboard throws the |keyboardchanges| event, and it seems that the event is thrown before the show animation is completed, so the calculated height is wrong.

This fact, could be another issue with the other dialogs and the SHB, so we should investigate it
Attachment #8528913 - Flags: review?(timdream)
(Assignee)

Comment 3

5 years ago
Posted image simpin_shb
Comment on attachment 8528913 [details] [review]
Proposed patch

Redirect review to John (or Alive if John feels not capable of reviewing) since I am not familiar with these timing anymore.
Attachment #8528913 - Flags: review?(timdream) → review?(jlu)
Comment on attachment 8528913 [details] [review]
Proposed patch

I believe we should have Alive review this.
Attachment #8528913 - Flags: review?(jlu) → review?(alive)
Comment on attachment 8528913 [details] [review]
Proposed patch

Nice to me!
Attachment #8528913 - Flags: review?(alive) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/d018933a981e9819aa1abe92f573d870d67e499d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S1 (5dec)
This issue is verified fixed on Flame 2.2.

Result: The number keypad is displayed properly on the SIM PIN screen with SHB enabled.

Device: Flame 2.2 (319mb, KK, Full Flash)
Build ID: 20141205040202
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: e7f3e6fee15e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.