[FFOS2.0][Woodduck][SMS]MS can't receive the SMS until read the class0 message.

RESOLVED DUPLICATE of bug 1105857

Status

P1
normal
RESOLVED DUPLICATE of bug 1105857
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned, NeedInfo)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
DEFECT DESCRIPTION:
 >MS can't receive the SMS until read the class0 message.
 
  REPRODUCING PROCEDURES:
 1.Receive a class0 message from the Now SMS server.
 2.Press the home key after receive the class0 message.
 3.Send a Class 1 message to the test phone-->KO
 
  EXPECTED BEHAVIOUR:
 The Class1 message can be received,and when you enter SMS app to read the Class1 message,MS will display the Class0 message firstly,after you press OK key,then you can read the class1 message.
 
 Note:The behaviour on Soul3.5 is OK,please refer to it.
 
 >Office number:0752-2639346
 
  ASSOCIATE SPECIFICATION:
  TEST PLAN REFERENCE:
  TOOLS AND PLATFORMS USED:
  USER IMPACT:
  REPRODUCING RATE:100%
  For FT PR, Please list reference mobile's behavior:
I think this happens because we use window.alert to display class0 messages. window.alert stops the application until it's finished.

The solution is likely to move off window.alert to display class0 messages.

Comment 2

4 years ago
Hi Gary,
Could you please help to check comment from Julien per comment 1? Thanks!
Blocks: 1054172, 1080481
blocking-b2g: --- → 2.0M?
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(gchen)
Created attachment 8528989 [details] [review]
GitHub pull request URL (CustomDialog, wip)

(In reply to Julien Wajsberg [:julienw] from comment #1)
> I think this happens because we use window.alert to display class0 messages.
> window.alert stops the application until it's finished.
> 
> The solution is likely to move off window.alert to display class0 messages.

Just attaching wip patch for custom dialog from bug 1082067 in case we decide to go with it.
According to comment #3, we have WIP patch here so clean ni?
Flags: needinfo?(gchen)

Comment 5

4 years ago
Ask Kai-Zhen land patch on bug 1094083

Updated

4 years ago
Flags: needinfo?(jocheng)

Updated

4 years ago
Blocks: 1080337
Depends on: 1094083, 1082067
Flags: needinfo?(jocheng)
Just wanted to note that issue from comment 0 won't be fixed by patch for bug 1094083. Moreover if we decide to fix this bug with CustomDialog (as in attachment 8528989 [details] [review]), then bug 1094083 isn't really required, but still nice to have :)

Also maybe useful to one who will pick this bug up: I see some other issue with outdated Thread List(new threads aren't added, last message text on existing thread isn't updated) when we receive ordinary message if app with active class-0 message "alert" is hidden via Home button.

Comment 7

4 years ago
(In reply to Oleg Zasypkin [:azasypkin] from comment #6)
> Just wanted to note that issue from comment 0 won't be fixed by patch for
> bug 1094083. Moreover if we decide to fix this bug with CustomDialog (as in
> attachment 8528989 [details] [review]), then bug 1094083 isn't really required, but
> still nice to have :)
Hi Oleg, Thank you for the information. Do you see other option than CustomDialog will fix the problem as well? If not I think we can try CustomDialog first and see whether the problem will solve. partner request this fix pretty urgent because they need this in order to pass certification.
Will you request review for patch https://bugzilla.mozilla.org/attachment.cgi?id=8517276?

> 
> Also maybe useful to one who will pick this bug up: I see some other issue
> with outdated Thread List(new threads aren't added, last message text on
> existing thread isn't updated) when we receive ordinary message if app with
> active class-0 message "alert" is hidden via Home button.
Do we need another bug for this?

Thank you very much!
Flags: needinfo?(azasypkin)

Updated

4 years ago
blocking-b2g: 2.0M? → 2.0M+
(In reply to Josh Cheng [:josh] from comment #7)
> (In reply to Oleg Zasypkin [:azasypkin] from comment #6)
> > Just wanted to note that issue from comment 0 won't be fixed by patch for
> > bug 1094083. Moreover if we decide to fix this bug with CustomDialog (as in
> > attachment 8528989 [details] [review]), then bug 1094083 isn't really required, but
> > still nice to have :)
> Hi Oleg, Thank you for the information. Do you see other option than
> CustomDialog will fix the problem as well? 

Nope, don't think that we can fix this without removing real "window.alert".

> If not I think we can try CustomDialog first and see whether the problem will solve. partner request
> this fix pretty urgent because they need this in order to pass certification.
> Will you request review for patch
> https://bugzilla.mozilla.org/attachment.cgi?id=8517276?

Patch for v2.0 branch will differ from the one for master. I've prepared draft patch for v2.0m branch [1], can someone apply it and check whether it fixes issue from comment 0? I believe it should, but admit that I don't know how to generate real class-0 messages without local workaround. This particular patch contains new l10n strings that is probably too late for v2.0m, but if it works we can think of something less l10n-intrusive :)

[1] https://github.com/azasypkin/gaia/commit/9037f861f267e6075b9ac86991679c9339467483.patch

> > Also maybe useful to one who will pick this bug up: I see some other issue
> > with outdated Thread List(new threads aren't added, last message text on
> > existing thread isn't updated) when we receive ordinary message if app with
> > active class-0 message "alert" is hidden via Home button.
> Do we need another bug for this?

Okay, false alarm, it was just bug in my local patch to emulate class-0 messages :) _But_ I investigated a bit  further and the problem seems more serious and affects other cases as well, see bug 1105857.
Flags: needinfo?(azasypkin) → needinfo?(jocheng)
(Reporter)

Comment 9

4 years ago
Dear Mozilla, What can I do for you?

Comment 10

4 years ago
Hi!

Draft patch for v2.0m branch is available. Could you apply it and check whether it fixes issue?
Thanks

--
Keven
Flags: needinfo?(sync-1)
(Reporter)

Comment 11

4 years ago
(In reply to comment #10)
 > Comment from Mozilla:Hi!
 > Draft patch for v2.0m branch is available. Could you apply it and check whether
 > it fixes issue?
 > Thanks
 > --
 > Keven
 
 OK. Is that the patch in this link?
 
 [1] https://github.com/azasypkin/gaia/commit/9037f861f267e6075b9ac86991679c9339467483.patch
(In reply to sync-1 from comment #11)
> (In reply to comment #10)
>  > Comment from Mozilla:Hi!
>  > Draft patch for v2.0m branch is available. Could you apply it and check
> whether
>  > it fixes issue?
>  > Thanks
>  > --
>  > Keven
>  
>  OK. Is that the patch in this link?
>  
>  [1]
> https://github.com/azasypkin/gaia/commit/
> 9037f861f267e6075b9ac86991679c9339467483.patch

Yep, taken from bug 1105857 (attachment 8530119 [details] [review])
Okay as we agreed offline and per suggestion of Device Team let's dupe this bug to more generic one - bug 1105857.

Hey @sync-1@bugzilla.tld, please comment on bug 1105857 instead once you get results.

Thanks a lot!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jocheng)
Resolution: --- → DUPLICATE
Duplicate of bug: 1105857

Updated

4 years ago
Blocks: 1107999

Updated

4 years ago
No longer blocks: 1107999
(Reporter)

Comment 14

4 years ago
Dear Dengwei,
 
 这个问题已解决,对应的内部PR,测试部已经验证通过并关闭了,请关闭此PR,谢谢!
 
 PS: Mozilla内部仍在讨论style一致性问题,等他们确定下来后或许对现在的style会有所改变。
You need to log in before you can comment on or make changes to this bug.