AwesomeBar's CMD+Enter keyboard shortcut searches default search engine instead of loading "www.*.com" website

RESOLVED WORKSFORME

Status

()

Firefox
Location Bar
P1
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox35 unaffected, firefox36 unaffected)

Details

(Whiteboard: [fxsearch][unifiedautocomplete])

(Reporter)

Description

3 years ago
STR:
1. In a clean profile, switch the default search engine from Google to any other search provider, such as Yahoo or Amazon.
2. In the AwesomeBar, enter a random string of characters.
3. Press CMD+Enter keyboard shortcut.

RESULT:
CMD+Enter is supposed to prepend "www." and append ".com" to the current AwesomeBar string, but instead it searches the current search engine. For some reason, this doesn't seem to happen if with the default search engine Google.

This is a regression in Nightly 36 build 2014-11-25. I bisected this regression to this pushlog:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9a355d616187&tochange=bf9071999612

* Blair: does this problem sound like fallout from bug 1097106 or bug 1067903?
Flags: needinfo?(bmcbride)

Updated

3 years ago
Blocks: 995091

Updated

3 years ago
Depends on: 1105456

Comment 1

3 years ago
Isn't this a dupe of bug 448486?
Flags: needinfo?(cpeterson)
(Reporter)

Comment 2

3 years ago
(In reply to alex_mayorga from comment #1)
> Isn't this a dupe of bug 448486?

The problem sounds similar, but this bug is a very recent regression in Nightly 36 build 2014-11-25.
Flags: needinfo?(cpeterson)
Recent regression, tracking.
tracking-firefox36: ? → +
Component: Search → Location Bar
This should not be an issue anymore with disabled unified complete, I can't reproduce it, at least.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bmcbride)
Resolution: --- → WORKSFORME
no wait, the bug is valid for unified complete, it just doesn't have to tracked.
Status: RESOLVED → REOPENED
status-firefox36: affected → unaffected
tracking-firefox36: + → ---
Resolution: WORKSFORME → ---
Blocks: 1157952
Whiteboard: [fxsearch][unifiedautocomplete]
Priority: -- → P1
Flags: firefox-backlog+
I can't repro this in a current nightly with browser.urlbar.unifiedcomplete=true after changing the default engine to yahoo.
I just tried again to repro and failed. Even when the urlbar is showing the first entry as "Search with Yahoo", ctrl+enter adds the "http://www." and ".com" and goes to that address.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.