[Flame][Contacts]The "Show password" item can't be unchecked.

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: wangxin, Assigned: mellis)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.0M unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [facebook][fb:escalated][6830])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8528969 [details]
Bug video: 1516.MP4

[1.Description]:
[Flame 2.0 & 2.1 & 2.2][Contacts]The "Show password" item can't be unchecked after you check it.
Found time:15:16
See attachment:1516.MP4 and logcat_1516.txt

[2.Testing Steps]: 
1.Launch Contacts.
2.Tap Settings, turn on "Sync friends".
3.Input a Facebook account, but input error password.
4.Tap "Log In", input some chars in password box.
5.Tap the "Show password" item.
**The password display normally.
6.Tap the "Show password" item again.

[3.Expected Result]: 
6.The item should be uncheck, and the password should not display.

[4.Actual Result]: 
6.The "Show password" can't be uncheck, the password still display. Sometimes, after step 6, tap the "Show password" again, the "Show password" can't be check.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0

Flame 2.2 build:
Gaia-Rev        c5bad6d78c5fe168e3bb894fc5cb70902c9b19b1
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c9cfa9b91dea
Build-ID        20141123040209
Version         36.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8528971 [details]
Bug log: logcat_1516.txt
status-b2g-v2.0M: --- → unaffected
The facebook login page is not owned by the gaia team. At first, I would think this is an issue on the FB site. But we have a different behavior in bug 1105206 and I can't reproduce this issue with the latest Firefox Nightly. Do you have an idea of what could be the problem, Jose?
Flags: needinfo?(jmcf)

Comment 3

4 years ago
I can reproduce it with latest master in Flame. No idea but it would be good to report the problem to Facebook, to Harald, perhaps?
Flags: needinfo?(jmcf)
Can you have a look at this Harald?
Flags: needinfo?(hkirschner)
+Michael to file a bug with FB.
Flags: needinfo?(hkirschner) → needinfo?(mellis)
(Assignee)

Comment 6

4 years ago
Bug reconfirmed as of today on Flame 2.0 reference device.

Will reach-out to Facebook with this issue in our next Bug update to fb team.  

Keeping NI on myself for tracking purposes
Status: NEW → ASSIGNED
Component: Gaia::Contacts → Preinstalled B2G Apps
Priority: -- → P3
Product: Firefox OS → Tech Evangelism
Whiteboard: [facebook]
(Assignee)

Updated

4 years ago
Assignee: nobody → mellis
(Assignee)

Comment 7

4 years ago
This issue is not reproducible on other devices/browsers.

This bug is now behaving differently.

Old behavior:  Tapping "show password" exposed password for user to read, subsequent taps do not hide/unhide password.

New Behavior: Tapping "show password" does not reveal password for user to read. Subsequent taps do not hide/unhide password. 

Facebook has been informed of this issue. At this time, Facebook will not designate resources to address this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mellis)
Resolution: --- → WONTFIX
(Assignee)

Updated

4 years ago
Blocks: 869192
(Assignee)

Updated

4 years ago
Whiteboard: [facebook] → [facebook][fb:escalated][6830]
You need to log in before you can comment on or make changes to this bug.