Closed Bug 1105208 Opened 5 years ago Closed 5 years ago

regression: (null) title for Bookmarks Toolbar, Bookmarks Menu, Unsorted Bookmarks

Categories

(Toolkit :: Places, defect, major)

defect
Not set
major
Points:
2

Tracking

()

VERIFIED FIXED
mozilla36
Iteration:
37.1
Tracking Status
firefox36 --- verified
firefox37 --- verified

People

(Reporter: mano, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

Attached patch patch (no test yet) (obsolete) — Splinter Review
Ugh.

QueryRowToResult must know that the shortcut-title is void.

Patch attached. Test coming later today.
Attachment #8528982 - Flags: review?(mak77)
Comment on attachment 8528982 [details] [diff] [review]
patch (no test yet)

Review of attachment 8528982 [details] [diff] [review]:
-----------------------------------------------------------------

yeah, we need a test.

::: toolkit/components/places/nsNavHistory.cpp
@@ +3904,5 @@
>    }
>  
>    if (IsQueryURI(url)) {
>      // Special case "place:" URIs: turn them into containers.
>      nsRefPtr<nsNavHistoryResultNode> resultNode;

move close to the first usage please, as it was before

@@ +3927,5 @@
> +      if (itemId != -1) {
> +        rv = aRow->GetUTF8String(nsNavBookmarks::kGetChildrenIndex_Guid,
> +                                 resultNode->mBookmarkGuid);
> +        NS_ENSURE_SUCCESS(rv, rv);
> +      }

could we move this just after QueryRowToResult? doesn't look like there's a good reason to nest these 2 ifs.
Attachment #8528982 - Flags: review?(mak77)
Duplicate of this bug: 1105478
Mano, we need to fix this before end of the week (next week we merge to Aurora)
Flags: needinfo?(mano)
Attached patch patch + test (obsolete) — Splinter Review
Flags: needinfo?(mano)
Attachment #8529894 - Flags: review?(mak77)
Attached patch patch + testSplinter Review
Attachment #8529894 - Attachment is obsolete: true
Attachment #8529894 - Flags: review?(mak77)
Attachment #8529921 - Flags: review?(mak77)
Attachment #8529921 - Flags: review?(mak77) → review+
"(no title)" displayed here too instead of the correct name.
https://hg.mozilla.org/mozilla-central/rev/601b38d36da8
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Target Milestone: mozilla37 → mozilla36
Flags: qe-verify?
Flags: firefox-backlog+
Flags: qe-verify? → qe-verify+
QA Contact: andrei.vaida
Reproduced the bug on an older nightly from 2014-11.26.

This is now verified fixed on Aurora 36.0a2 (2014-12-01) and Nightly 37.0a1 (2014-12-02), using Windows 7 64-bit, Ubuntu 12.04 LTS 32-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
Fixed on nightly. 37.0a1 (2014-12-02)
You need to log in before you can comment on or make changes to this bug.