Closed Bug 1105228 Opened 8 years ago Closed 8 years ago

Adjust Firefox-34.0-build2 release in Balrog to offer on beta channel

Categories

(Release Engineering :: Release Automation: Other, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nthomas, Unassigned)

References

Details

Attachments

(2 files)

We have this in https://aus4-admin.mozilla.org/releases/Firefox-34.0-build2/data -
  "fileUrls": {
    "*": {
      "partials": {
        "Firefox-34.0b11-build1": "http://download.mozilla.org/?product=firefox-34.0-partial-34.0b11&os=%OS_BOUNCER%&lang=%LOCALE%",
        "Firefox-33.1.1-build1": "http://download.mozilla.org/?product=firefox-34.0-partial-33.1.1&os=%OS_BOUNCER%&lang=%LOCALE%",
        "Firefox-32.0.3-build1": "http://download.mozilla.org/?product=firefox-34.0-partial-32.0.3&os=%OS_BOUNCER%&lang=%LOCALE%",
        "Firefox-33.1-build3": "http://download.mozilla.org/?product=firefox-34.0-partial-33.1&os=%OS_BOUNCER%&lang=%LOCALE%",
        "Firefox-33.0.3-build2": "http://download.mozilla.org/?product=firefox-34.0-partial-33.0.3&os=%OS_BOUNCER%&lang=%LOCALE%"
      },
      "completes": {
        "*": "http://download.mozilla.org/?product=firefox-34.0-complete&os=%OS_BOUNCER%&lang=%LOCALE%"
      }
    },
    "betatest": {
      "partials": {
        "Firefox-34.0b11-build1": "http://stage.mozilla.org/pub/mozilla.org/firefox/candidates/34.0-candidates/build2/update/%OS_FTP%/%LOCALE%/firefox-34.0b11-34.0.partial.mar",
        "Firefox-33.1.1-build1": "http://stage.mozilla.org/pub/mozilla.org/firefox/candidates/34.0-candidates/build2/update/%OS_FTP%/%LOCALE%/firefox-33.1.1-34.0.partial.mar",
        "Firefox-32.0.3-build1": "http://stage.mozilla.org/pub/mozilla.org/firefox/candidates/34.0-candidates/build2/update/%OS_FTP%/%LOCALE%/firefox-32.0.3-34.0.partial.mar",
        "Firefox-33.1-build3": "http://stage.mozilla.org/pub/mozilla.org/firefox/candidates/34.0-candidates/build2/update/%OS_FTP%/%LOCALE%/firefox-33.1-34.0.partial.mar",
        "Firefox-33.0.3-build2": "http://stage.mozilla.org/pub/mozilla.org/firefox/candidates/34.0-candidates/build2/update/%OS_FTP%/%LOCALE%/firefox-33.0.3-34.0.partial.mar"
      },
      "completes": {
        "*": "http://stage.mozilla.org/pub/mozilla.org/firefox/candidates/34.0-candidates/build2/update/%OS_FTP%/%LOCALE%/firefox-34.0.complete.mar"
      }
    }
  },

For beta we care about beta-localtest, beta-cdntest, and beta channels, so they're currently going to use the * wildcard block rather than betatest. The firefox-34.0-partial-34.0b11 product is set to point into the candidates directory so it works ok, but firefox-34.0-complete points into releases and the files aren't there yet.

We probably have to create a copy of the blob and adjust, and use it just for the beta prod+test channels.
Manually adjusted fileUrls to
* use firefox-34.0build2-complete bouncer product for channel wildcard
* s/betatest/beta-localtest/
* drop release partials
and programatically drop release partials in platform-locale blocks.

We'll need to setup the bouncer product with it's locations.
Thanks Nick. As far as fixing this in automation goes, I think we can add explicit blocks for beta and beta-localtest as part of the submission?
I added Nick's blob to Balrog prod and updated the beta-localtest rule to point at it. I've also created the "firefox-34.0build2-complete" bouncer product w/ locations. AFAICT, the "Firefox-34.0-Partial-34.0b11" product is fine as it is, with locations such as "/firefox/candidates/34.0-candidates/build2/update/linux-i686/:lang/firefox-34.0b11-34.0.partial.mar".

QE confirmed that the beta-localtest tests are passing now.
Yup, I definitely needed to know this to know which update channel to run update tests on. Luckily I tried a small batch of sample tests a couple of times first and was able to ask Ben rather than get lost in the weeds blaming the automation or something else. It's good there is a bug to refer to for the explanation and it helped to be able to refer the automation team to it too. Tests look ok now!
Had to create a second blob because we wanted to enable the whatsnew page for en-US only. I created this, and another rule with a higher priority + locale set.
(In reply to Ben Hearsum [:bhearsum] from comment #5)
> Created attachment 8529208 [details]
> Firefox-34.0-build2-beta-2-whatsnew.json
> 
> Had to create a second blob because we wanted to enable the whatsnew page
> for en-US only. I created this, and another rule with a higher priority +
> locale set.

Nevermind, turns out we can't do this, so I reverted it. I left the blob in because it doesn't hurt to have it:
14:43 <@gavin> bhearsum: hmm, just tried a manual test and I didn't get a whatsnew
14:43 <@gavin> (post-update)
14:44 <@gavin> oh
14:44 <@gavin> I see that this won't work after all
14:44 < ashughes> well then I really don't know what's going on right now
14:44 <@gavin> we only check for snippet-provided pages in-product when the version changes
14:44 < ashughes> I haven't been filled in on all the special details
14:44 < ashughes> all I was asked to do was run the update automation on the beta channel once the updates were pushed
14:45 <@gavin> lmandel, bhearsum: so we just can't force whatsnew for 34.0build2
14:45 < bhearsum> gavin: ok, well i guess i'll revert all the whatsnew stuff that i did, to make things less confusing
14:45 <@gavin> lmandel: we will ahve to live for no whatsnew in 34.0 on beta
QA signed off on beta, thanks for all the work here Ben.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Blocks: 1105485
You need to log in before you can comment on or make changes to this bug.