Send Link does not send correct link from a Youtube playlist

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: therube, Unassigned)

Tracking

SeaMonkey 2.30 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
URL: https://www.youtube.com/watch?v=v5iz_JBtuDQ&list=ALGLx1orRGw4W468FoBov8nOUP-nKO2apH

File | Send Link

> https://www.youtube.com/watch?v=v5iz_JBtuDQ&list=ALGLx1orRGw4W468FoBov8nOUP-nKO2apH

That is fine.

Now advance to the next song in the playlist - either by clicking the >> icon in the player or by clicking the next song in the list.

Note that the URL as displayed on the Location Bar has changed.

File | Send Link

The original link is again sent, not the newly displayed link.

Opening a new link in a new tab will work correctly.
FF (Email Link) does send the expected links (with Gmail).
(Youtube is not working, but that is a different issue.)
 
 
Original link
> https://www.youtube.com/watch?v=v5iz_JBtuDQ&list=ALGLx1orRGw4W468FoBov8nOUP-nKO2apH
Next song in playlist
> https://www.youtube.com/watch?v=2shXfsqOXwM&index=2&list=ALGLx1orRGw4W468FoBov8nOUP-nKO2apH
Next
> https://www.youtube.com/watch?v=8i8Z0Vzo_8g&list=ALGLx1orRGw4W468FoBov8nOUP-nKO2apH&index=3
Next
> https://www.youtube.com/watch?v=NXOyXbhN0Lc&index=4&list=ALGLx1orRGw4W468FoBov8nOUP-nKO2apH
Next
> https://www.youtube.com/watch?v=_1wS3LsCxuE&index=5&list=ALGLx1orRGw4W468FoBov8nOUP-nKO2apH

Note the actual clip changes each time, &v=...
The index also changes, &index=...

Neither change are reflected when using the Send Link command.
 
 
Don't know if related?

> Warning: window.controllers is deprecated. Do not use it for UA detection.
> Source File: chrome://editor/content/ComposerCommands.js
> Line: 198

198:

> window.content.controllers.insertControllerAt(0, controller);
(Reporter)

Comment 1

3 years ago
Looks to be a regression as picking some old version (SeaMonkey 2.19 as it was) does work correctly.
(Reporter)

Comment 2

3 years ago
WFM (but leaving it open for the time being).

It was pointed out that this is now working as expected with SeaMonkey 2.31, & it is.
Wonder why?
(Reporter)

Comment 3

2 years ago
Guess no one is going to answer my question in Comment 2 ;-).

Oops. Resolving, WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.