Implement the code to copy a window for bug 18808

RESOLVED WORKSFORME

Status

SeaMonkey
Session Restore
--
enhancement
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: Brian 'netdragon' Bober, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
No not a dupe of Bug 18808.

We have been talking about this for over a year and still haven't come up to any
solution. It is one of only about 10 bugs that have this many or more votes!!!

I like Andrew's compromise.. its very thoughtful... but heheh its not practical
imho. I feel instead of making both parties happy it will make one semi-happy
and one totally angry as the back history has a rogue member in it.

What we need is someone who is willing to take this under their wings (not me -
please don't even ask :) - If someone implements it - it will probably be added
because of the number of votes on this bug. So this is a chance for someone to
make a real impact. I mean a HUGE impact.

Please correct me if I'm wrong... but what we need is:

A) Code to implement the copying of a window.
1) HTML data
2) Forward history
3) Back history
4) Javascript/images/etc...
5) Make sure popup windows for ads etc don't do this or it would slow things
down. (Maybe later)

C) Test its performance and fine-tune it. Copy memory in bulk, etc.


2+3 are probably best done every time in order not to complicate things.

Bug 18808 should only have to do with how to trigger it because otherwise it is
way too broad. 

Therefore... I am opening a new bug Called "Implement the code to copy a window"
and copying this text in. This code will have nothing to do with the
implementation of the UI for the bug but only have to do with the actual copying
of the window. It can be tested using javascript or whatever. i.e. :
copywindow(); in the URL bar.

Questions:
Would it be best if it copied the page as-is including pages recieved from CGI
without re-sending the CGI? Therefore data entered into forms would be copied
along with data recieved so the user wouldn't have to wait... Or would this
cause a mess?
(Reporter)

Updated

16 years ago
Blocks: 18808
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
sharing the love. cc jrgm for when this too complicated for me to keep track of :-)
this is a broad browser feature not a feature of session history. Session
history apis have all the methods required to make a copy of it. 
Assignee: radha → pchen
Component: History: Session → XP Apps

Comment 3

16 years ago
We are trying to make windows open faster and be easier to use, not slower and
more complicated.  wontfix.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

16 years ago
If you mark this bug WONTFIX then you should mark bug 18808 WONTFIX too. This
bug is only for implementing the code to copy a window. Code doesn't add any
memory footprint to windows as the code for a class only has one copy. As for
Windows opening faster... Speed will have to be a tradeoff for implementing bug
18808. As not ALL windows openened will need to have the back/forward history,
etc. This will not affect the speed for all windows. This bug was made to break
up the tasks necessary for implementing bug 18808 into more specific tasks. As
this bug is necessary to be resolved for 18808 and bug 18808 hasn't been
resolved WONTFIX then this one shouldn't either. 
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 5

16 years ago
gee, thanks.  wontfix.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

16 years ago
Reopening as per 18808
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 7

16 years ago
-> nobody
Assignee: pchen → nobody
Status: REOPENED → NEW
(Reporter)

Updated

16 years ago
Keywords: helpwanted
(Reporter)

Updated

16 years ago
Summary: Implement the code to copy a window → Implement the code to copy a window for bug 18808
(Reporter)

Comment 8

16 years ago
Note: this code should in no way change the performance of opening a new window
the old way.

Comment 9

15 years ago
This should also apply to tabs.

Comment 10

14 years ago
This is good! Make the code *first*, leave the implementation up to someone else
because those guys in 18808 could argue forever. It gets my vote.

Comment 11

14 years ago
EEK! I ran out of votes. Sorry. I'm in the cc list tho.
Product: Core → Mozilla Application Suite
Assignee: nobody → jag
QA Contact: claudius

Comment 12

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 13

8 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

6 years ago
> Therefore... I am opening a new bug Called "Implement the code to copy a window"
> and copying this text in. This code will have nothing to do with the
> implementation of the UI for the bug but only have to do with the actual copying
> of the window. It can be tested using javascript or whatever. i.e. :
> copywindow(); in the URL bar.

The SessionStore backend which we now have provides all the functionality needed so marking as WORKSFORME.

The front end UI will be fixed in Bug 449728 - Write front-end code to use backend Drag & Drop tabs between browser windows functionality.
Assignee: jag-mozilla → nobody
Status: NEW → RESOLVED
Last Resolved: 16 years ago6 years ago
Component: UI Design → Session Restore
Depends on: 36810
Keywords: helpwanted
QA Contact: session.restore
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.