Bookmark Keyword searches auto go to the default search engine

RESOLVED WORKSFORME

Status

()

Toolkit
Places
P1
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: jaws, Unassigned)

Tracking

({regression})

unspecified
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox36 affected)

Details

(Whiteboard: [fxsearch][unifiedautocomplete])

STR:
Add a keyword search for mxr.mozilla.org using the keyword 'mxr'
In the address bar, type 'mxr foo'
Hit Enter

ER:
A search for 'foo' is performed at mxr.mozilla.org

AR:
A search at the default engine is performed for the search URL of MXR. In the Google case, it is:
https://www.google.com/search?q=%7B%22url%22%3A%22http%3A%2F%2Fmxr.mozilla.org%2Fmozilla-central%2Fsearch%3Fstring%3Dfoo%26find%3D%26findi%3D%26filter%3D%5E%5B%5E%5C0%5D*%2524%26hitlimit%3D%26tree%3Dmozilla-central%22%2C%22input%22%3A%22mxr+foo%22%7D&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=firefox-nightly&channel=fflb
status-firefox36: --- → affected
Are you sure this is due to bug 1067903 and not due to bug 1083469?

Is it still broken if you restart the browser?

Updated

3 years ago
Flags: qe-verify+
Flags: in-testsuite?
Flags: firefox-backlog+
Keywords: regression
Duplicate of this bug: 1105484
just to be sure, here you are referring to a bookmark keyword, right? not a search engine keyword (set through the search engines management panel)
Flags: needinfo?(jaws)
Yes, a bookmark keyword. Sorry for the ambiguity.
Flags: needinfo?(jaws)
With 2014-11-27 Nightly on Windows 7 I can no longer reproduce this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #5)
> With 2014-11-27 Nightly on Windows 7 I can no longer reproduce this.

we disabled unified complete, so that doesn't matter. We still need to fix this.
Blocks: 995091
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

3 years ago
Duplicate of this bug: 1104716

Updated

3 years ago
Summary: Keyword searches auto go to the default search engine → Bookmark Keyword searches auto go to the default search engine
Blocks: 1157952
Whiteboard: [fxsearch][unifiedautocomplete]
Priority: -- → P1
I can't reproduce this in nightly with unified autocomplete enabled.  I created a bookmark with keyword "bug". When I enter "bug" in the URL bar, the popup shows "bugzilla.mozilla.org: " with a search icon. When I enter more characters (eg, "bug foo") the popup reflects this (ie "bugzilla.mozilla.org: foo" still with a search icon. Pressing enter executes the search as expected.
Jaws, can you please try and repro this again?
Flags: needinfo?(jaws)
I can't reproduce this bug on Nightly 2015-05-04. It's been working for me for some time now. Thanks for the ping.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Flags: needinfo?(jaws)
Resolution: --- → WORKSFORME

Updated

2 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.