login screen fails with illegal array reference

RESOLVED WORKSFORME

Status

()

Bugzilla
User Interface
P2
critical
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Kevin Brannen, Assigned: myk)

Tracking

Details

(Reporter)

Description

16 years ago
I just checked out the latest code from CVS and installed.  First time I ran it
and tried to enter a new bug, it sent me to the login screen (appropriately) in
enter_bug.cgi.  However, after it wrote out the password field, it displayed:

Content-type: text/html
Software error:

Can't use an undefined value as an ARRAY reference at CGI.pl line 1018.

Which looks like:

        # Add all the form fields into the form as hidden fields
        # (except for Bugzilla_login and Bugzilla_password which we
        # already added as text fields above).
        foreach my $i ( grep( $_ !~ /^Bugzilla_/ , keys %::FORM ) ) {
          if (scalar(@{$::MFORM{$i}}) > 1) {                            #1018
            # This field has multiple values; add each one separately.
            foreach my $val (@{$::MFORM{$i}}) {

I found that if I change the "if" to:

          if (defined($::MFORM{$i}) && scalar(@{$::MFORM{$i}}) > 1) {   #1018
then the problem goes away and the screen comes up correctly.
*** Bug 106982 has been marked as a duplicate of this bug. ***
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.16
(Reporter)

Comment 2

16 years ago
IIRC, the way to trigger this bug is to have an brand new empty DB, i.e. do this
like it is the first time BZ is on the system, instead of doing an "upgrade".
The duplicate bug of this was seen on bmo.
The fix given in this bug has been made, according to my current copy of CGI.pl.
Let's call this WORKSFORME, and have a new bug if it occurs again.

Gerv
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Fix was a fix to bug #120543.
clearing target milestone on resolved non-FIXED bugs so they'll get re-triaged
if they get reopened.
Target Milestone: Bugzilla 2.16 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.