Adblock Plus is causing Firefox to hang for 1-2 seconds every 10ish seconds with e10s enabled.

RESOLVED DUPLICATE of bug 1102643

Status

()

defect
RESOLVED DUPLICATE of bug 1102643
5 years ago
5 years ago

People

(Reporter: johan.charlez, Unassigned)

Tracking

unspecified
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s?)

Details

Attachments

(1 attachment)

9.84 MB, text/plain
Details
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Adblock Plus version: 2.6.6

STR:
1. Enable e10s on the latest Nightly.
2. Make sure that Adblock Plus is enabled.

Actual:
Firefox "hickups"/freezes every 10 seconds or so for approximately 1-2 seconds.
No interaction with mouse or keyboard is possible.
Has someone tried profiling this?
tracking-e10s: --- → ?
Component: General → Untriaged
Posted file Profile
(In reply to :Gijs Kruitbosch from comment #1)
> Has someone tried profiling this?

Attached it since it was too large to upload.

Firefox more or less froze completely when trying to capture the profile, so I'm not sure I managed to capture anything of note.
Looking at this, it looks like a ton of CPOW traffic. I suspect the prefetching work in bug 1102643 will help with this, as it'll cut down on CPOW traffic.

Johan - are you comfortable applying and building patches? If so, you could try applying the patches in bug 1102643 - I'd be curious to know if you felt they cause performance improvements.
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #3)
> Johan - are you comfortable applying and building patches? If so, you could
> try applying the patches in bug 1102643 - I'd be curious to know if you felt
> they cause performance improvements.

Sure, I'll see about doing it this weekend.
Having difficulty reproducing this as of https://hg.mozilla.org/mozilla-central/rev/1162e4a4d7a2, how about leaving this open until we know for sure?
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #3)
> Looking at this, it looks like a ton of CPOW traffic. I suspect the
> prefetching work in bug 1102643 will help with this, as it'll cut down on
> CPOW traffic.
> 
> Johan - are you comfortable applying and building patches? If so, you could
> try applying the patches in bug 1102643 - I'd be curious to know if you felt
> they cause performance improvements.

(In reply to Johan C from comment #5)
> Having difficulty reproducing this as of
> https://hg.mozilla.org/mozilla-central/rev/1162e4a4d7a2, how about leaving
> this open until we know for sure?

So I ran into this again. I'm not sure why I couldn't reproduce it at that one point.

I've now been able to reproduce the bug on my laptop, and I'm building with the patches in bug 1102643 applied. Will report back in an hour-ish (Windows build time yay!).
Mach and automatic incremental builds to the rescue!

However, with those two patches applied I'm unable to install adblock plus from about:addons:
It throws:
ReferenceError: RemoteAddonsParent is not defined multiprocessShims.js:67:2
Could not read chrome manifest 'file:///c:/Code/Firefox/obj/dist/bin/browser/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.
1417633862585	addons.xpi	WARN	Failed to install C:\Users\johanc\AppData\Local\Temp\tmp-6s6.xpi from https://addons.mozilla.org/firefox/downloads/file/283972/adblock_plus-2.6.6-tb+an+fx+sm.xpi?src=api: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: XPI_loadBootstrapScope :: line 4287"  data: no] Stack trace: XPI_loadBootstrapScope()@resource://gre/modules/addons/XPIProvider.jsm:4287 < XPI_callBootstrapMethod()@resource://gre/modules/addons/XPIProvider.jsm:4408 < AI_startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:5753 < next()@self-hosted:943 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:870 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:749 < this.PromiseWalker.scheduleWalkerLoop/<()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:691 < <file:unknown>
1417633862587	addons.xpi	WARN	removeActiveInstall: could not find active install for https://addons.mozilla.org/firefox/downloads/file/283972/adblock_plus-2.6.6-tb+an+fx+sm.xpi?src=api

----------------

What now? :)
Flags: needinfo?(mconley)
Is it possible the patches are bit-rotted by now?
Yes, that is possible. I have asked the author to supply new ones.
Flags: needinfo?(mconley)
So it turns out I made a typo when fixing some merge conflicts.

Tested with adblock+ for a few minutes and it looks like bug 1102643 will fix this. I'm seeing some choppy input in textboxes, but that's probably a different bug, something like bug 972423.
Sounds like this will get fixed by the prefetching work. Thanks Johan!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1102643
You need to log in before you can comment on or make changes to this bug.