Intermittent browser_lastAccessedTab.js | selected tab has the current timestamp (difference: N)

RESOLVED FIXED in Firefox 36

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: dao)

Tracking

({intermittent-failure})

unspecified
Firefox 37
x86
Linux
intermittent-failure
Points:
2
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(firefox34 unaffected, firefox35 unaffected, firefox36 fixed, firefox-esr31 unaffected)

Details

Yes, this started after bug 980231 landed.

11:31:25 INFO - 452 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js
11:31:25 INFO - 453 INFO checking window state
11:31:25 INFO - 454 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js | selected tab has the current timestamp
11:31:25 INFO - 455 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js | new tab hasn't been selected so far
11:31:25 INFO - 456 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js | new tab has the current timestamp after being selected
11:31:25 INFO - 457 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js | original tab has old timestamp after being deselected
11:31:25 INFO - 458 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js | new tab has the current timestamp since it's still selected - Got 1417030285487, expected 1417030285488
11:31:25 INFO - Stack trace:
11:31:25 INFO - chrome://mochikit/content/browser-test.js:test_is:834
11:31:25 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js:step4:30
11:31:25 INFO - null:null:0
11:31:25 INFO - 459 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js | took 442ms
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Assignee: nobody → dao
Blocks: 980231
Points: --- → 2
Flags: qe-verify-
Flags: firefox-backlog+
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Iteration: --- → 37.1
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

3 years ago
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 15

3 years ago
309 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js | selected tab has the current timestamp (difference: 3) -

(from comment 12)

This is post-patch. Should we increase the fuzz treshold to something more like 10?
Flags: needinfo?(dao)
(Assignee)

Comment 16

3 years ago
I just decreased the delay between the steps to 10ms (bug 980231 comment 19), so a 10ms tolerance would be too much and not reliably catch a regression. I've increased the tolerance to 5 for now:

https://hg.mozilla.org/integration/fx-team/rev/6283ef6b1257

If this is not enough, both the tolerance and the delay will need to be increased.
Flags: needinfo?(dao)
https://hg.mozilla.org/mozilla-central/rev/67ad36ab89c1
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
Comment hidden (Treeherder Robot)

Updated

3 years ago
Duplicate of this bug: 1105919

Updated

3 years ago
Summary: Intermittent browser_lastAccessedTab.js | new tab has the current timestamp since it's still selected - Got 1417030285487, expected 1417030285488 → Intermittent browser_lastAccessedTab.js | selected tab has the current timestamp (difference: N)
status-firefox34: --- → unaffected
status-firefox35: --- → unaffected
status-firefox36: --- → fixed
status-firefox-esr31: --- → unaffected
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 23

3 years ago
increased the tolerance from 5 to 15:

https://hg.mozilla.org/integration/fx-team/rev/f46dc1e8d238

Updated

3 years ago
Iteration: 37.1 → 37.2
(Assignee)

Comment 24

3 years ago
Apparently this bug wasn't updated when the patch was merged to mozilla-central.

http://hg.mozilla.org/mozilla-central/rev/f46dc1e8d238
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 36 → Firefox 37
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.