Mozilla crashes halfway through loading a Quicktime Movie Trailer

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: pbergsag, Assigned: peterlubczynski-bugs)

Tracking

({crash})

Trunk
PowerPC
Mac System 8.6
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.5+) Gecko/20011116
BuildID:    2001111608

The browser crahsed while playing a Quicktime movie trailer. The trailer had
played for about a minute before the crash.

Reproducible: Sometimes
Steps to Reproduce:
1.Play a Qucktime trailer
2.Sometimes there is a crash.


Actual Results:  A crash while playing a Quictime trailer.

Expected Results:  No crash.

I will include a Macsbug STDLOG stack trace.
(Reporter)

Comment 1

17 years ago
Created attachment 58189 [details]
MacsBug STDLOG
also see bug 110528, and bug 110441

Comment 3

17 years ago
reporter, could yo upls tell us the version fo your quicktime plugin? Thx.
(Reporter)

Comment 4

17 years ago
I am using the Quicktime plug-in 5.0.2. The Quicktime updater says I have the
latest Quicktime software installed.

Comment 5

17 years ago
pls attach atestcase where u crash almost consistently. That would help a lot , 
thanx.
(Reporter)

Comment 6

17 years ago
This bug may be hard to pin point since it occurs randomly. I suspect that this
bug likelier to occur the long the aplication is kept running. The only hope for
tracking down this bug is the stck trace from Macsbug. The only test case I can
think of is to :

1. Launch the browser and browse for a while (at least 45 min.)

2. Play some Quicktime content.

3. Sometimes the browser will crash during the Quicktime playback while at other
times there will be no crash.

I am sorry that I am unable to provide a test case to pinpoint this bug. I will
post better test case if when browsing I find out how to reproduce this bug.
(Reporter)

Comment 7

17 years ago
I have found a test case which shows this bug:

1. Goto http://www.apple.com/trailers/sony/dark_blue_world.html
2. Click to play the trailer.
3. Wait until the Quicktime trailer has played ~50% of the file.
4. The browser crashes into Macsbug evry time this Quicktime clip is played.

I am using Mac OS 8.6 256 MB ran installed with a broadband cable internet
connection. I have the latest Quicktime plug-in installed.
(Reporter)

Comment 8

17 years ago
BTW I forgot to mention I tested the Quicktime plug-in tonight using the new
0.9.6 Milestone.

Comment 9

17 years ago
pbergsag, can you reproduce this problem using Mozilla 0.9.6? If so, are Talkback reports 
generated? If so, please let us know the appropriate report ID's.

If not, per the Mozilla Bug Writing Guidelines, please attach the results of MacsBug "how" 
and "sc" operations following a crash.

Populating URL field with the value suggested by pbergsag in Additional Comment #7 on 
this bug.

Comment 10

17 years ago
Since this is a crash, raising Severity and adding "crash" keyword.
Severity: normal → critical
Keywords: crash

Comment 11

17 years ago
Whoops, confirming that Mac/2001112011 quit because an error of Type 2 occurred about 
halfway through this QuickTime movie as described by pbergseg, this under Mac OS 9.2.1. 
No Talkback; will turn MacsBug on and try to get a stack crawl.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Quicktime: Crash playing a Quicktime Movie Trailer → Mozilla crashes halfway through loading a Quicktime Movie Trailer

Comment 12

17 years ago
Hmm, well, on my second try, the movie displayed fine from start to finish; no
crash.

pbergseg, please follow through on the second paragraph of my Comment #9 hereon.
(Assignee)

Comment 13

17 years ago
Does clearing your cache have any effect? A stdlog from MacsBugs would be helpful!
Assignee: av → peterlubczynski
(Assignee)

Comment 14

17 years ago
Oops, my mistake, didn't see the attachment. Looks like it's crashing inside the
plugin, but going through a timer null event:

0F2E0290    PPC  1D358F34  nsPluginInstanceOwner::Notify(nsITimer*)+00088
0F2E0230    PPC  1DFE7970  ns4xPluginInstance::HandleEvent(nsPluginEvent*, 

This sounds similar to a few other bugs....
Status: NEW → ASSIGNED
(Reporter)

Comment 15

17 years ago
I attempted to reproduce this bug using Mozilla Build ID 2001112308 to provide
the additional information using the Macsbug Data (since talkback builds on the
Mac never seem to send any reports) and could not recreate this bug. Something
appears to have changed in this build that has fixed(?) this bug. As the
oringinal reporter I am reporting that this bug WFM using the build 2001112308.
BTW I tested using the apple.com  quicktime trailer site.
(Assignee)

Comment 16

17 years ago
ok--->WFM

Reporter: If you experience this crash again, please feel free to reopen this
bug. Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.