IPv6: DNS: Win32 builds do not query for AAAA records

RESOLVED FIXED in mozilla1.6alpha

Status

()

defect
P1
normal
RESOLVED FIXED
18 years ago
11 years ago

People

(Reporter: taya, Assigned: darin.moz)

Tracking

(Blocks 1 bug)

Trunk
mozilla1.6alpha
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

18 years ago
On Win32 platform, IPv6 support is missing.
There are two problems

1.No DNS support for IPv6 address resolution.
mozilla uses async DNS resolv function for Win32/IPv4, but there is no async
version of IPv6 resolve function on Win32.

2.IPv4 mapped IPv6 address
mozilla converts IPv4 address to IPv4 mapped IPv6 address internally
And try to connect on AF_INET6 socket.
But WinXP doesn't support IPv4 mapped IPv6 address.
If mozilla use same method to support IPv6 like other OSes that suport IPv4
mapped IPv6 address, IPv4 connection will be broken on WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

18 years ago
This is really an NSPR bug.

We can either change the product to NSPR, or
open an NSPR bug and make this bug depend on
the NSPR bug.

Comment 2

18 years ago
nspr
Assignee: neeti → wtc
Component: Networking → NSPR
Product: Browser → NSPR

Updated

18 years ago
QA Contact: benc → wtc

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → Future

Comment 3

17 years ago
Also affects Windows 2000 using Microsoft research IPv6 stack as of Mozilla1.1b

Does problem #1 (no DNS support) stop IPv6 support in the browser? It's pretty
normal to use IPv4 DNS transport to return IPv6 records (AAAA, A6, etc).

Comment 4

17 years ago
I believe problem #1 is an inability to look up AAAA records at all.

Updated

17 years ago
Blocks: IPv6

Updated

17 years ago
Priority: P2 → P1
Target Milestone: Future → 4.3

Comment 5

17 years ago
My statement in comment #1 is wrong.  This should
be a Browser:Networking bug.  Problem #1
(WSAAsyncGetHostByName can't look up IPv6 addresses)
is definitely a Necko issue.

Problem #2 (Windows XP doesn't support IPv4-mapped
IPv6 addresses) can be handled in NSPR.  I opened
NSPR bug 175340 for problem #2 and made this bug
depend on it.
Assignee: wtc → new-network-bugs
Status: ASSIGNED → NEW
Component: NSPR → Networking
Depends on: 175340
Product: NSPR → Browser
QA Contact: wtc → benc
Target Milestone: 4.3 → ---
-> gordon
Assignee: new-network-bugs → gordon
Assignee

Comment 7

17 years ago
just to summarize what this means for necko... the XP_WIN codepath needs to
simply be the same as the XP_UNIX codepath.  of course, this may impact
performance negatively, so perhaps support for IPv6 is a good reason to start
using a thread pool for the XP_UNIX DNS impl.

Comment 8

17 years ago
*** Bug 182088 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Based on wtc's comments, I've narrowed the scope of the summary.
Summary: IPv6 support missing on Win32 → IPv6: DNS: Win32 builds do not query for AAAA records

Comment 10

16 years ago
*** Bug 218388 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Depends on: 205726
Assignee

Comment 11

16 years ago
-> me
Assignee: gordon → darin
Target Milestone: --- → mozilla1.6alpha
Assignee

Comment 12

16 years ago
ok, this is fixed now that my patch for bug 205726 is in =)

NOTE: it is only fixed if you are running WinXP (or if you have a sufficiently
upgraded version of ws2_32.dll on your system).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.