Closed Bug 1105678 Opened 7 years ago Closed 6 years ago

[Pinyin][Zhuyin] Sometimes tapping "x" button on input box to clear character won't successful

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 unaffected, b2g-master unaffected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected
b2g-master --- unaffected

People

(Reporter: mlien, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #972210 +++

Build Information
Gaia-Rev        5372b675e018b6aac97d95ff5db8d4bd16addb9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f34377ae402b
Build-ID        20141126161202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.193631
FW-Date         Wed Nov 26 19:36:42 EST 2014
Bootloader      L1TC10011880

Steps to Reproduce
  0. Should have Pinyin/Zhuyin keyboard
  1. Launch Contacts app -> Press "+" to invoke Add contact page
  2. Focus on input box
  3. Input any character -> Press "x" button to clear character
  4. Repeat step 3 10~15 times

Expected Results
Clear character successfully

Actual Results
Sometimes keyboard will be re-invoked and character won't be cleared

Reproduction Frequency: 
30%
Summary: [Pinyin][Zhuyin] Tapping "X" button on the text field to clear it does not clean out candidates, and tapping these candidates has no effect → [Pinyin][Zhuyin] Sometimes tapping "x" button on input box to clear character won't successful
Hi Mike,

Just want to double confirm, you mean clicking on the round [X] button at the end of the input field?
That button is implemented by the Content app, in this case, Contact App, so this might be a per-app issue.

Thanks.
Flags: needinfo?(mlien)
Whiteboard: [p=1]
Refer to comment 1, change component to Gaia::Contacts
Component: Gaia::Keyboard → Gaia::Contacts
Flags: needinfo?(mlien)
This might have been fixed by bug 1094709. Mike, could you check again against a more recent build?
Flags: needinfo?(mlien)
The patch only on master but doesn't uplift to v2.1, today's v2.1 build still can reproduce this issue
Gaia-Rev        5372b675e018b6aac97d95ff5db8d4bd16addb9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f34377ae402b
Build-ID        20141128001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141128.034107
FW-Date         Fri Nov 28 03:41:18 EST 2014
Bootloader      L1TC10011880
Flags: needinfo?(mlien)
Depends on: 1094709
qawanted to test this out in Pinyin Keyboard. Please WFM if this is fixed on master already.
Component: Gaia::Contacts → Gaia::Keyboard
This issue is not reproducible on Flame 2.5 master, however, as stated on comment 4, it is still reproducible on Flame 2.1. So I'm not sure if WFM is the right way to label this bug. If it's not going to be fixed, a wontfix seems more appropriate.

Tested on:
Device: Flame 2.5 (319MB, full flashed, KK)
BuildID: 20150804030213
Gaia: caba8b26c52d3c771e9ea6fe288acdaf74c7707e
Gecko: 5b54831761b1
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.1 (319MB, full flashed, KK)
BuildID: 20150724001207
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Based on comment 6, the issue is still not reproducible on the latest master. 2.1 development is now frozen. We can close this bug. Thanks for checking this again.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.