Closed Bug 1105695 Opened 7 years ago Closed 7 years ago

Allow apps to create windows overlaying other apps

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1101029

People

(Reporter: ferjm, Unassigned)

Details

We need a way for apps to create windows overlaying other apps. We currently have at least two use cases in Gaia for this in 2.2:

1. Contact quick view [1]
2. Buddy-up

The current proposal for this is explained at [2]

[1] https://wiki.mozilla.org/Gaia/Contacts/Bookmarks#UX_Proposal
[2] https://wiki.mozilla.org/Gaia/Contacts/Bookmarks#Overlay_window
Here is the proposal for BuddyUp: https://wiki.mozilla.org/BuddyUp/Phase2
As stated in this document, I'll think we'll also need some minimal work in Gecko to pass this new kind of window to window.open.
We already have bug 1101029 opened for this and more people cced, let's continue the discussion there.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1101029
No longer blocks: 1097768
You need to log in before you can comment on or make changes to this bug.