Closed Bug 1105720 Opened 5 years ago Closed 4 years ago

Intermittent test_empty_resource.html | timed out without getting an error event - expected PASS

Categories

(Core :: DOM: Core & HTML, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla41
Tracking Status
firefox36 --- fixed
firefox37 --- fixed
firefox38 --- wontfix
firefox38.0.5 --- wontfix
firefox39 --- wontfix
firefox40 --- fixed
firefox41 --- fixed
firefox-esr31 --- unaffected
firefox-esr38 --- wontfix
b2g-v2.2 --- affected
b2g-master --- fixed

People

(Reporter: cbook, Assigned: jwwang)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

b2g_emulator_vm mozilla-inbound debug test mochitest-debug-12

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=4259619&repo=mozilla-inbound

02:44:16 INFO - 3 INFO TEST-UNEXPECTED-FAIL | /tests/dom/media/test/test_empty_resource.html | timed out without getting an error event - expected PASS
15s are not enough for the slow B2G emulator. It took 23s to reach decoding metadata. We would just make it 6 times (90s) to make it very very robust.

02:51:12     INFO -  3 INFO TEST-START | dom/media/test/test_empty_resource.html
02:51:35     INFO -  [Child 779] WARNING: Decoder=40292970 ReadMetadata failed, res=80004005 HasValidMedia=0: file ../../../gecko/dom/media/MediaDecoderStateMachine.cpp, line 2216
02:51:35     INFO -  [Child 779] WARNING: Decoder=40292970 Decode metadata failed, shutting down decoder: file ../../../gecko/dom/media/MediaDecoderStateMachine.cpp, line 2173
02:51:35     INFO -  [Child 779] WARNING: Decoder=40292970 Decode error, changed state to SHUTDOWN due to error: file ../../../gecko/dom/media/MediaDecoderStateMachine.cpp, line 2146
Assignee: nobody → jwwang
Status: NEW → ASSIGNED
Attachment #8558288 - Flags: review?(cpearce)
Attachment #8558288 - Flags: review?(cpearce) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d1fa3876ca44
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
(In reply to TBPL Robot from comment #81)
Status: RESOLVED → REOPENED
Flags: needinfo?(jwwang)
Resolution: FIXED → ---
I guess it is another root cause for it is unusual for 4 tests to time out in a row... I will investigate it.
Flags: needinfo?(jwwang)
Due to bug 1161405, independent events dispatched a thread pool sometimes will run in sequence. And due to the deadlock in bug 1161416, the state machine cycle of this test case will never run until the deadlocked event is finished.

Either bug 1161405 or bug 1161416 should fix the timeout here.
Depends on: 1161405, 1161416
Per comment 215, bug 1161405 has fixed the timeout of this test case. I would like to remove the flaky timeout so if it time out again in the future, we know there are other root causes.
Attachment #8558288 - Attachment is obsolete: true
Attachment #8605017 - Flags: review?(cpearce)
Attachment #8605017 - Flags: review?(cpearce) → review+
Thanks for the review.
https://hg.mozilla.org/mozilla-central/rev/437176aee57d
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: mozilla38 → mozilla41
Any chance we can backport the fix to other branches?
I will uplift bug 1161405 and this bug to Aurora and Beta.
Flags: needinfo?(jwwang)
wontfix for esr38/b2g37 then?
Flags: needinfo?(jwwang)
Yes. For we don't run tests on esr38/b2g37 as often as Aurora/Beta, I don't think it's worth the effort to uplift. However, I am fine with that if you see it fit to uplift also to esr38/b2g37.
Flags: needinfo?(jwwang)
Both branches are going to be around for at least another year, so I'm very likely to disable the test otherwise. But depending on the relative risks, that may still be the more-preferable option. What do you think?
The risk is low in uplifting bug 1161405. I will also uplift to esr38/b2g37 as far as its sustainability concerned.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.