Fix intermittent failure in test_sms_contact.py

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: viorela, Assigned: viorela)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Test test_sms_contact.py has failed in latest master build: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.b2g-inbound.ui.functional.smoke/1424/HTML_Report/

I ran the automated test locally several times and I was able to reproduce the failure. 
Reproduction rate: 1/10

Traceback (most recent call last):
File "/var/jenkins/2/workspace/flame-kk-319.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
testMethod()
File "/var/jenkins/2/workspace/flame-kk-319.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/contacts/test_sms_contact.py", line 49, in test_sms_contact
self.assertTrue(new_message.keyboard.is_keyboard_displayed)
AssertionError: False is not true

Device firmware (date) 	27 Nov 2014 05:13:32
Device firmware (incremental) 	eng.cltbld.20141127.081321
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	27 Nov 2014 04:04:22
Gaia revision 	609f3985df16
Gecko build 	20141127042803
Gecko revision 	41eb311949de
Gecko version 	36.0a1

We need to investigate and fix the issue
(Assignee)

Updated

4 years ago
Assignee: nobody → viorela.ioia

Comment 1

4 years ago
Weird thing is that in the screenshot it is definitely displayed.

I guess the `is_keyboard_displayed` logic is buggy!
(Assignee)

Comment 2

4 years ago
Created attachment 8530263 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/26537

'new_message.keyboard.is_keyboard_displayed' works as expected.
The issue here seems to be the fact that sometimes it takes a little more time for the keyboard to appear.
I think that replacing the assert with a wait will fix the intermittent failure. 
I also started an adhoc with this fix and results are looking good: jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/367/HTML_Report/
Attachment #8530263 - Flags: review?(robert.chira)
Attachment #8530263 - Flags: review?(florin.strugariu)
(Assignee)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-s5]
Attachment #8530263 - Flags: review?(florin.strugariu) → review+
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.