Search suggestions missing from search bar when using twitter and yahoo as default search engine

RESOLVED INVALID

Status

()

Firefox
Search
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

34 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8529792 [details]
Screencast showing the issue

Reproducible on Firefox 34.0.5 RC (build ID: 20141126041045)

STR:
1. Open Firefox with a clean profile
2. Change the default search engine to Yahoo or Twitter
3. Close the Preferences window
4. Enter a string in search bar

Expected results: Search suggestions are displayed.

Actual results: No search suggestions are displayed.

Notes:
1. After unfocusing the search bar and move the focus back, search suggestions will be displayed the second time, using yahoo I could only find this issue the first time I write a string - only using yahoo.
2. Using twitter I get no search suggestions what so ever even after several tries.
3. This is reproducible across platforms.
4. Screencast attached showing the issue.
Florian - If this is an in product regression, this looks somewhat serious. Can you please investigate?

ni Gavin for visibility.
Flags: needinfo?(gavin.sharp)
Flags: needinfo?(florian)
For the Twitter part, I think it's just that the Twitter provider doesn't support suggestions.

For Yahoo, I can't reproduce, so unless there's evidence showing otherwise, I would be tempted to believe it's temporary server issues. If the server doesn't reply, in the browser console you'll get a message saying "SearchSuggestionController: HTTP Timeout". It happened to me a few times while I was developing, the Yahoo suggestions seemed less reliable than the Google ones. It's also been reported in bug 1105329.
Flags: needinfo?(florian)
(Reporter)

Comment 3

3 years ago
(In reply to Florian Quèze [:florian] [:flo] from comment #2)
> For the Twitter part, I think it's just that the Twitter provider doesn't
> support suggestions.
> 
> For Yahoo, I can't reproduce, so unless there's evidence showing otherwise,
> I would be tempted to believe it's temporary server issues. If the server
> doesn't reply, in the browser console you'll get a message saying
> "SearchSuggestionController: HTTP Timeout". It happened to me a few times
> while I was developing, the Yahoo suggestions seemed less reliable than the
> Google ones. It's also been reported in bug 1105329.

Using Yahoo I do get 'SearchSuggestionController: HTTP Timeout' in console so it might be a server issue but for Twitter the console is empty.
(Reporter)

Comment 4

3 years ago
We've further investigated and we reproduced this issue with a debug build, also reproduced in 34 beta builds so this is not a regression. We also got a stacktrace from a Firefox 34.0.5 build, maybe it tells something. I don`t know if this really is a server issue or not. 

Florian, can you confirm or infirm that this is server side or not, as in bug 1105329? Or can you contact someone who can say for sure?

The complete testing information can be seen in this etherpad: https://etherpad.mozilla.org/Bug1105794

If there is anything we can help with further on please needinfo me.
Flags: needinfo?(florian)
(In reply to Florian Quèze [:florian] [:flo] from comment #2)
> For the Twitter part, I think it's just that the Twitter provider doesn't
> support suggestions.

Just to confirm that Twitter doesn't have an application/x-suggestions+json url, so missing suggestions are expected.

For Yahoo the url is set, for example: https://search.yahoo.com/sugg/ff?output=fxjson&appid=ffm&command=mozilla

One thing that I noticed: I tried loading random URLs with Network Monitor open, they usually take less than 170ms. But I've seen at least one request taking almost 500ms (can't reproduce reliably). Maybe we should increase the timeout? 
As it is, this bug looks like a lot like a dupe of bug 1105329.
I spent some time looking at the Yahoo issue with Bogdan. When the suggestions failed to display and we had the "HTTP timeout" error message in the Browser Console, the network monitor showed that the request took 520ms to complete. Given that we have a timeout of 500ms in the code after which we stop waiting and display only history results, it totally makes sense that we don't have suggestions displayed in that case.

Given this, I'm not very confident this is a server or network issue. One thing to note is that it seems people who reproduced this are all in Europe. It's possible response times from yahoo servers are much better for people in the US.
Flags: needinfo?(florian)
(In reply to Florian Quèze [:florian] [:flo] from comment #6)
> Given this, I'm not very confident this is a server or network issue. One
> thing to note is that it seems people who reproduced this are all in Europe.

Just to clarify comment 5: suggestions are displayed reliably for me (Italy), and requests don't go near the 500ms limit.
(In reply to Florian Quèze [:florian] [:flo] from comment #6)

> Given this, I'm not very confident this is a server or network issue.

I meant "I'm no_w_ very confident this is a server or network issue."

(In reply to Francesco Lodolo [:flod] from comment #7)

> Just to clarify comment 5: suggestions are displayed reliably for me
> (Italy), and requests don't go near the 500ms limit.

They are displayed most of the time for me. I managed to see the HTTP timeout error once today (out of many attempts). I saw the error a couple times during the last few weeks, but not frequently enough that it would have worried me.

Bodgan seems to be able to reliably reproduce the issue, and he's in Romania.
Florian (and Gavin), does this mean you want to respin 34?  

It sounds like increasing the request timeout limit may help, but we don't know that it will fix this problem. I don't think it is worth holding up 34 and 34.0.5 for an intermittent issue.
Flags: needinfo?(florian)
(In reply to Liz Henry :lizzard from comment #9)
> Florian (and Gavin), does this mean you want to respin 34? 

No.
Flags: needinfo?(florian)
No, not something we can fix (increasing the timeout hurts autocomplete result latency).

We should bring this up with our contacts at Yahoo and see what they can do to improve search suggestion request latency in general.
Flags: needinfo?(gavin.sharp) → needinfo?(kev)

Comment 12

3 years ago
In speaking with Yahoo, they typically see latency in the US of ~10-20ms, with a minimum standard of 100ms. We brought this issue to their attention three days ago and they've been monitoring the suggest API and haven't seen any abnormal behaviour. I haven't seen any examples of this either and, given bug 1105329 I'd like to also make sure there isn't anything we've introduced. Increasing the timeout is something we shouldn't have to do, and it'd be good to start collecting additional information on when this shows up (specifically outbound IP address, location, etc.). I want to make sure it's not our network, or intermediary content networks. (also, was the old code a little more resilient, e.g. retries after timeouts, or is it effectively the same stuff in the new UI?)
Flags: needinfo?(kev)
(In reply to Kev Needham [:kev] from comment #12)
> In speaking with Yahoo, they typically see latency in the US of ~10-20ms,
> with a minimum standard of 100ms.

I've seen this occasionally (like once a week) from France. Bogdan has seen this slightly more frequently, from Romania. AFAIK nobody reported seeing this bug from the US.
The latency of Yahoo US server when accessed from Europe is not something we can fix.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Comment 15

3 years ago
We can retry, though, no?
(In reply to Kev Needham [:kev] from comment #15)
> We can retry, though, no?

We can retry contacting people from Yahoo; what I meant is that there's nothing in the Firefox code that needs fixing here.
You need to log in before you can comment on or make changes to this bug.