Closed Bug 1105802 Opened 6 years ago Closed 6 years ago

Add Beta tag to the Rooms standalone page

Categories

(Hello (Loop) :: Client, defect, P1)

x86_64
Windows 7
defect
Points:
1

Tracking

(firefox35+ fixed, firefox36 fixed, firefox37 fixed)

RESOLVED FIXED
mozilla37
Iteration:
37.1
Tracking Status
firefox35 + fixed
firefox36 --- fixed
firefox37 --- fixed
Blocking Flags:
backlog Fx35+

People

(Reporter: mreavy, Unassigned)

Details

Attachments

(1 file, 2 obsolete files)

Since the feature is still in Beta during Fx35, we want to add the Beta ribbon to the Rooms standalone page.  We want to do this before the next update of the standalone app
backlog: --- → Fx35+
Priority: -- → P1
Minimalistic approach. Note that the issue with RWD will be addressed along bug 1104051.
Attachment #8530299 - Flags: review?(mdeboer)
Thanks, Niko!
Assignee: nobody → nperriault
Fixed regression introduced by previous patch.
Attachment #8530299 - Attachment is obsolete: true
Attachment #8530299 - Flags: review?(mdeboer)
Attachment #8530317 - Flags: review?(mdeboer)
[Tracking Requested - why for this release]:
This patch is for the standalone app. We may choose to uplift it for the sake of shared code with desktop.  Marking this as tracking Fx35 so we get this fixed before Fx35 goes to Release.
Comment on attachment 8530317 [details] [diff] [review]
Added beta tag to standalone room layout. Patch v2

I'd like us to land the remaining open Rooms bugs this week.  This just needs a review from Mike or Mark to land (whoever gets to it first).
Attachment #8530317 - Flags: review?(standard8)
Attachment #8530317 - Flags: review?(standard8) → review?(dmose)
Comment on attachment 8530317 [details] [diff] [review]
Added beta tag to standalone room layout. Patch v2

r=dmose with a comment added about what factors influenced the choice of 50px.  If it makes sense to switch to rems for scalability, I'd be ok with that too.
Attachment #8530317 - Flags: review?(dmose) → review+
I discovered an issue with that patch when resizing the browser window where the Firefox logo was hidden entirely; so here's new version of the patch fixing that situation.

Re commenting on the 50px value, I don't have a clue how to explain that choice except "because it's where it looks best"… Converting to rem wouldn't improve scalability as we're speaking svg and background here.
Attachment #8530317 - Attachment is obsolete: true
Attachment #8530317 - Flags: review?(mdeboer)
Attachment #8531738 - Flags: review?(dmose)
Comment on attachment 8531738 [details] [diff] [review]
Added beta tag to standalone room layout.

r=dmose
Attachment #8531738 - Flags: review?(dmose) → review+
https://hg.mozilla.org/integration/fx-team/rev/656951a75391
Iteration: --- → 37.1
Points: --- → 1
Target Milestone: --- → mozilla37
https://hg.mozilla.org/mozilla-central/rev/656951a75391
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8531738 [details] [diff] [review]
Added beta tag to standalone room layout.

Approval Request Comment
[Feature/regressing bug #]: Rooms standalone

[User impact if declined]: minor merge conflicts possible in future patches

[Describe test coverage new/current, TBPL]: manual test, on m-c

[Risks and why]: no risk, pure standalone 

[String/UUID change made/needed]: none
Attachment #8531738 - Flags: approval-mozilla-beta?
Attachment #8531738 - Flags: approval-mozilla-aurora?
Attachment #8531738 - Flags: approval-mozilla-beta?
Attachment #8531738 - Flags: approval-mozilla-beta+
Attachment #8531738 - Flags: approval-mozilla-aurora?
Attachment #8531738 - Flags: approval-mozilla-aurora+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.