Create new Operator Shelf form can be accessed using an account without permissions

RESOLVED WONTFIX

Status

Marketplace
Curation Tools
P3
normal
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: Madalin Cotetiu, Unassigned)

Tracking

Avenir
2015-02-17
x86_64
Windows 7
Points:
---

Details

(Whiteboard: [ktlo], URL)

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Open https://marketplace-dev.allizom.org/operators/login and log in with an account without permissions to create operator shelfs
2. Click on the Operator Dashboard link

Expected results:
"You do not have permission to access this tool." message is displayed

Actual results: 
"There are no operator shelves.Create one?" message is displayed the user can click on "Create one" link and open the New Operator Shelf creation page

Notes/Issues:
Verified in FF36(Win7) Issue can be reproduced in mp-dev.
Screencast for this issue: http://screencast.com/t/B2grVdJgkA
BFFs with bug 1096951
Priority: -- → P3
Target Milestone: 2014-12-02 → ---
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2015-02-17
(Reporter)

Comment 2

4 years ago
Verified in FF38(Win7) in marketplace-dev.allizom.org
Please view this screencast: http://screencast.com/t/fSiAeldekq
Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [ktlo]
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → WONTFIX
Operator shelves are likely being retired due to carrier decisions.
You need to log in before you can comment on or make changes to this bug.