4.4 and 4.2 documentation links broken on bugzilla.org

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gerv, Assigned: justdave)

Tracking

Details

* Visit http://www.bugzilla.org/docs/
* Click "html", "pdf", "text" or "api" next to 4.4 or 4.2

Result: 404

Expected: actual docs

Gerv
Anyone know who has the power to look into or fix this?

Gerv
Flags: needinfo?(justdave)
Can't locate File/Copy/Recursive.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at docs/makedocs.pl line 30.

Sounds like that perl module is missing on the site build box.  Not sure where that is, ops probably knows.
Assignee: website → server-ops-webops
Component: bugzilla.org → WebOps: Other
Flags: needinfo?(justdave)
Product: Bugzilla → Infrastructure & Operations
QA Contact: default-qa → nmaul
Version: 4.5.6 → other
Looks like this is in puppet...

Index: modules/webapp/manifests/admin/static.pp
===================================================================
--- modules/webapp/manifests/admin/static.pp	(revision 97861)
+++ modules/webapp/manifests/admin/static.pp	(working copy)
@@ -12,6 +12,7 @@
       'perl-Template-Toolkit',
       'perl-XML-XPath',
       'perl-Template-XML',
+      'perl-File-Copy-Recursive',
       'libxslt',
       'sgml-common',
       'xml-common',

Trying to find out if this needs a CAB to push...
Assignee: server-ops-webops → justdave
Sending        modules/webapp/manifests/admin/static.pp
Transmitting file data .
Committed revision 97864.

Will watch and see if it builds on the next pass.
Status: NEW → ASSIGNED
And that changed the error message.

Can't locate Date/Format.pm in @INC (@INC contains: .. ../lib lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at ../Bugzilla/Error.pm line 24.
Index: modules/webapp/manifests/admin/static.pp
===================================================================
--- modules/webapp/manifests/admin/static.pp	(revision 97864)
+++ modules/webapp/manifests/admin/static.pp	(working copy)
@@ -13,6 +13,7 @@
       'perl-XML-XPath',
       'perl-Template-XML',
       'perl-File-Copy-Recursive',
+      'perl-TimeDate',
       'libxslt',
       'sgml-common',
       'xml-common',

Sending        modules/webapp/manifests/admin/static.pp
Transmitting file data .
Committed revision 97870.
Can't locate Math/Random/ISAAC.pm in @INC (@INC contains: .. ../lib lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at ../Bugzilla/RNG.pm line 17.

Ummm... wth does it need Math::Random::ISAAC to build the docs?  I'm not installing that one without a full change req because it's going to pull a crapton of dependencies.

Comment 8

4 years ago
Math::Random::ISAAC has very few dependencies
Looking at the cron emails, whatever broke broke between November 25th and November 26th
looks like it's the tip docs that are failing, and we don't even actually host those on bugzilla.org anymore, it links to readthedocs.  So we shouldn't even be building that one.

Index: etc/docs-versions
===================================================================
RCS file: /www/bugzilla-org/etc/docs-versions,v
retrieving revision 1.10
diff -u -r1.10 docs-versions
--- etc/docs-versions	25 Jan 2014 17:17:34 -0000	1.10
+++ etc/docs-versions	4 Dec 2014 20:09:28 -0000
@@ -16,7 +16,6 @@
 %::bzr_branches = (
   '4.2' => 'bugzilla/4.2',
   '4.4' => 'bugzilla/4.4',
-  'tip'  => 'bugzilla/trunk',
 );

 1;

Checking in etc/docs-versions;
/www/bugzilla-org/etc/docs-versions,v  <--  docs-versions
new revision: 1.11; previous revision: 1.10
done
Docs are live on the website, I'll consider this fixed.

Tip API docs are missing as a result of this, but it needs things fixed before it can be built, and that'll be another bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Duplicate of this bug: 1109591
This has broken again :-(

Currently 404ing:

* Trunk PDF (bug 1107565)
* Everything for 4.4 and 4.2 (i.e. stuff built from bzr)

justdave: only you have access to the relevant logs here, I think.

Gerv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Or we could just fix bug 1108076.

Gerv
So the problem here was that it was still trying to run Bugzilla. Didn't we fix that when we removed the "use Bugzilla" from the make-docs.pl script? Yes, but of course the docs build pulls from bzr, and bzr trunk is not updating from git right now.

I've disabled the building of trunk API docs _again_ to get everything else building:

Checking in etc/docs-versions;
/www/bugzilla-org/etc/docs-versions,v  <--  docs-versions
new revision: 1.13; previous revision: 1.12
done

We need to fix bug 1108076 (i.e. move to git) to fix this properly.

Gerv
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
This change has filtered through and all docs are now available on the website except for the API tip (as expected).

Gerv
You need to log in before you can comment on or make changes to this bug.