freemail.ukr.net displays incorrectly

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
3 years ago
9 days ago

People

(Reporter: Eugene, Unassigned)

Tracking

34 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8529886 [details]
Firefox.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127110442

Steps to reproduce:

1. open freemail.ukr.net
2. enter your credentials



Actual results:

Look on a screen: message list pushed to the right. Please see screenshot (Firefox.jpeg).


Expected results:

mwssage list should look like there is no empty space between message folders and message list. It should look like in other browsers, for example like this: http://storage9.static.itmages.com/i/14/1127/h_1417113441_1219517_ac4a2e2432.jpeg
People outside the Ukraine can't register for an address, so there's no way for me to reproduce this issue.

Does this not happen with other browsers?

Do you know enough html/CSS to be able to export a testcase (file > save as...) and anonymize it (ie so we can't read your email subject lines) while keeping the broken layout?
Component: Untriaged → Untriaged
Flags: needinfo?(ken20001)
Keywords: testcase-wanted
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
(In reply to :Gijs Kruitbosch from comment #1)
> People outside the Ukraine can't register for an address, so there's no way
> for me to reproduce this issue.
wow, I didn't know it
> Does this not happen with other browsers?
I tried Opera, Chromium. And they're displays it correctly.

> Do you know enough html/CSS to be able to export a testcase (file > save
> as...) and anonymize it (ie so we can't read your email subject lines) while
> keeping the broken layout?
If you could explain me a little what exectly to save, I'm ready to save it for you.
Flags: needinfo?(ken20001)
(Reporter)

Comment 3

3 years ago
Created attachment 8530942 [details]
freemail.tar.xz

freemail.ukr.net saved webpage with broken layout
(Reporter)

Comment 4

3 years ago
Please, look at attachment. There are saved (file > save as...) list of messages in freemail.ukr.net mailbox. I've created a new mailbox, so there is no problem with anonimity.
Thanks for the testcase, and for the patience - I'm sorry I got back to this so late.

The attached files look correct to me on Firefox 35 (current beta), 34 (current release) and 33, although I tested on OS X. Are you still seeing the same problem? Does the attachment look incorrect to you, too, when opened separately?

Have you tried opening the website (attached or "real" site) in Firefox's safe mode ( https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode ) ?
Flags: needinfo?(ken20001)
(Reporter)

Comment 6

3 years ago
Recently tested on F34 with completely new profile and started with -safe-mode. The issue still is.
Flags: needinfo?(ken20001)
Created attachment 8537933 [details]
Working screenshot

This is what this looks like on my Ubuntu VM on 34 - that's correct, right? Are you sure the testcase you attached correctly shows the issue you see with the "real" website?
Flags: needinfo?(ken20001)
Attachment #8537933 - Attachment description: Screen Shot 2014-12-17 at 17.38.30.png → Working screenshot
(Reporter)

Comment 8

3 years ago
Created attachment 8537941 [details]
testcase.mkv
Flags: needinfo?(ken20001)
(Reporter)

Comment 9

3 years ago
I just recored video for you. Please, look in attachment.
(Reporter)

Comment 10

3 years ago
Recently checked on Xubuntu VM and it's ok there. But also checked on Kubuntu VM and there is also like on my host Kubuntu-machine - this bug. So, as I understood, it is KDE only related (?)
(In reply to Eugene from comment #10)
> Recently checked on Xubuntu VM and it's ok there. But also checked on
> Kubuntu VM and there is also like on my host Kubuntu-machine - this bug. So,
> as I understood, it is KDE only related (?)

No idea... that just seems very strange to me. I don't know why there'd be something on the one machine that'd interfere with core functionality like layout, only on a specific machine, and even in safe mode / a clean(ish) profile.

Are both VMs/hosts using 64- or 32-bit Firefox? And are these official builds, or distro-provided builds? In the latter case, can you doublecheck with official builds? (I'd be surprised if that made a difference, but it's not unheard of and we've tried the more obvious routes at figuring out what's going on here...)
Flags: needinfo?(ken20001)
Oh... hang on. I guess it's possible that some elements on the page may be using OS default fonts and/or widgets, which might be different on KDE? Which might influence layout in some bizarre cases - but that'd most likely indicate an issue with the page itself and how it accomplishes the layout that it has, and it'd require some debugging of the CSS to figure out why it breaks with certain font sizes / widget sizes.
(Reporter)

Comment 13

3 years ago
Yes, I'm using official builds. The additional proof of it is tha I've already installed Kubuntu on several machines and this issue I'm seeing very long time. Also I recently checked Kubuntu 14.10 i386 LiveCD in VM and the problem still is.
Flags: needinfo?(ken20001)
Flags: needinfo?(gijskruitbosch+bugs)
I checked on a Kubuntu VM.

This problem is caused by the fact that on KDE, a native checkbox (in particular, the "select all" checkbox at the top of the table) is much bigger than on non-KDE, and so it protrudes into the content below it, causing things to shift. If you right click that checkbox, inspect element, and delete it, the content shifts back just fine.

This is an issue with the webpage's layout and how it deals with KDE native widgets, and not one we can fix in Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → INVALID
(Reporter)

Comment 15

3 years ago
It's understood. Thanks for explanation.
Keywords: testcase-wanted
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.