All users were logged out of Bugzilla on October 13th, 2018

Nightly 64-bit does not launch on Vista Business 64 bit

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: cirkumcizija, Unassigned)

Tracking

36 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141127030208

Steps to reproduce:

A few days ago (about November 25, 2014) I updated to the latest version of 64 bit Nightly on my 64-bit Vista Business. Since then, Nightly fails to launch and displays a message '[installation path]\firefox.exe is not a 32-bit application'. When I downgrade to an earlier build or version, the message disappears. The message also doesn't appear with the latest 32-bit builds of Nightly on the same machine. The odds are that something has regressed in the compilation or linking procedure of the building process. No system upgrages were performed, also other 64-bit software works just fine.


Actual results:

Nightly 64-bit does not launch on my 64-bit OS anymore since the latest builds (nov. 25 2014, supposedly)


Expected results:

Normal launch of Nightly 64-bit atop of a 64-bit Windows Vista Business OS.
This is an intentional decision. See bug 604967 and bug 1094013.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

4 years ago
This doesn't have any explanatory power. Why doesn't the same 'decision' apply to the 32-bit builds of Nightly as well? I think this could push me to choose using 64-bit Chromium instead.
(In reply to cirkumcizija from comment #2)
> This doesn't have any explanatory power. Why doesn't the same 'decision'
> apply to the 32-bit builds of Nightly as well?

Because 32-bit Firefox is already officially released.

> I think this could push me to
> choose using 64-bit Chromium instead.

Win64 Chromium does not work with Vista x64, either.
(Reporter)

Comment 4

4 years ago
First of all, Your argumentation skills leave me with expectations to see an improvement. Perhaps, this could help You deal with `non sequitur`s and other rhetological fallacies --> http://www.informationisbeautiful.net/visualizations/rhetological-fallacies/
In Your reply 
«Because 32-bit Firefox is already officially released»,
I don't see any logical link (causal relationship) why 64-bit Nightlies should have different features and minimum requirements against the OS than their 32-bit counterparts. The only difference ought to be processor architecture they depend on and consequently, the improvements brought by 64-bit CPU capabilities. After all, https://www.mozilla.org/en-US/mission/ states that «Our mission is to promote openness, innovation & opportunity on the Web». I don't realise how restricting users, who still run a supported OS (in my case, Vista 64-bit/Srv 2008 64-bit) from running Nightly 64-bit builds go along with promoting openness. Instead, it should be left available on as wide variety of OSes as possible. Ok, that's an opinion, but hopefully my arguments are ± convincing.
As per third part of the conversation, in the morning Chromium 64-bit worked very well on my 64-bit Vista machine. And still it does. Hope the user agent string tells it all Mozilla/5.0 (Windows NT 6.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2234.0 Safari/537.36
So pretty please, with sugar on top, think more, before you make `decisions` affecting user population. Perhaps a private build would have been o.k.?
You need to log in before you can comment on or make changes to this bug.