Closed Bug 1105905 Opened 5 years ago Closed 4 years ago

dailymotion.com offers a black screen with sound only when watching video in full screen

Categories

(Web Compatibility :: Mobile, defect, major)

Firefox 33
ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: chaochao.huang, Assigned: karlcow)

References

()

Details

(Whiteboard: [video] [country-all])

Step1:-
1.Use SIM data.
2.Open browser-->google.com-->Dailymotion.com.
3.Search video-->play video-->click on full screen.
4.Sound come but Screen black.
5.Not able to watch the video while click on full screen.
Summary: [FirefoxOS_v1.4][Browser] FFOS screen black & sound come when watch video in full screen in browser → [FirefoxOS_v1.4] [Browser] black screen, sound only when watching dailymotion.com video in full screen
Hi karl:

  I think this this also a compatible with firefox problem, and android firefox web browser also have this problem, please help to investigate, thanks a lot.
Flags: needinfo?(kdubost)
yong.ren

Did you use any specific search terms?
Flags: needinfo?(kdubost) → needinfo?(yong.ren)
For firefox OS,
1. go to dailymotion.
2. Click on any video
   ex: http://www.dailymotion.com/video/x2ccih1_taiwan-generation-tournesols-1_news
3. Type the play button
4. Sometimes an ads is played, sometimes not.
5. The video is black, nothing is happening.


The video is part of an iframe.

<iframe src="http://www.dailymotion.com/embed/video/x2ccih1?api=postMessage&amp;apiKey=ce08346aac01f35dc49e&amp;html=1&amp;id=f2e8b9a48b6b1d8&amp;info=0&amp;is_webapp=1&amp;logo=0" id="f2e8b9a48b6b1d8" title="Dailymotion video player" mozallowfullscreen="true" webkitallowfullscreen="true" allowfullscreen="true" class="video-player" frameborder="0" height="100%" width="100%"></iframe>


Sometimes I get the message:

   Media Not Supported
   The video could not be loaded, either because the 
   server or network failed or because the format is 
   not supported.

I also receive markup with "class="loader ios-loader" which makes me wonder if Firefox OS is detected as iOS.

<div style="display: none; margin-top: -22px;" class="loader ios-loader" id="loader">…

Checking their code: player-<unique_id>.js

  Modernizr.addTest('ua_mobile', function () {
    return t.match(/iPhone|iPod|CFNetwork|Android.*Mobile Safari|Windows Phone|IEMobile\/(?:9|1\d)|tizen|(Blackberry|BB10|BBOS; Touch).*Version\/10|Android; Mobile;.*Firefox|Mozilla\/\S+ \(Mobile;/i)
  }),

and more UA sniffing…

Still need to investigate a bit more.
(In reply to Karl Dubost :karlcow from comment #2)
> yong.ren
> 
> Did you use any specific search terms?

no, you can use any terms to search video in daily motions, and they all have same phenomenon.
Flags: needinfo?(yong.ren)
Dailymotion is being contacted.
Assignee: nobody → kdubost
Whiteboard: [video] [country-all]
Summary: [FirefoxOS_v1.4] [Browser] black screen, sound only when watching dailymotion.com video in full screen → dailymotion.com offers a black screen with sound only when watching video in full screen
I can't reproduce today on a Flame device. Watching video on DailyMotion opens the video(s) in full-screen, and both picure and sound is OK.
Hm..still an issue on Android
Works now :)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.