[1.3t][Intex Cloud FX] incorrect app name appears when downloading from marketplace

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: angelc04, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 8530023 [details]
device-2014-11-28-101056.png

Steps to reproduce
-------------------------------------------------------
1. Change system language to any indian language
2. Launch Marketplace and download an app
3. During the downloading process, pull down notification menu
   --> App name shows incorrectly for the downloading progress
4. After app is downloaded, "app installed" message pops up
   --> App name shows incorrectly

Please see attached screenshot.
Created attachment 8530024 [details]
device-2014-11-28-101152.png
Summary: [tarako][Intex Cloud FX] incorrect app name appears when downloading from marketplace → [1.3t][Intex Cloud FX] incorrect app name appears when downloading from marketplace
Not sure if this is a marketplace app problem or a notification bar problem...Luke, any comment?

Thanks
Flags: needinfo?(lchang)
Sorry for the late reply. Because I'm OOO and have no v1.3t device at hand, I only tested it on v2.0 flame but can't reproduce this issue.

To my knowledge, these strings are all rendered in system app ([1] & [2]) so it should be a L10N issue of the system app. According to the screenshots, it appears that there's an unexpected question mark in the keyword "{{ appName }}". I guess it is the cause.


[1] https://github.com/mozilla-b2g/gaia/blob/v1.3t/apps/system/js/app_install_manager.js#L226
[2] https://github.com/mozilla-b2g/gaia/blob/v1.3t/apps/system/js/app_install_manager.js#L425-L427
Flags: needinfo?(lchang)

Comment 4

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.