Feature Proposal: Ability to Alias Accounts

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: Synper311, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I'd like to see the ability to give an alias for a friendly name to the email accounts in the Email app.

For instance, I have the same email address for two separate email accounts (one is IMAP from AOL, one is Exchange ActiveSync from Outlook.com/Hotmail).

When I add both to the Email app, they're visiually indistinguishable from one another.

Furthermore, I'd prefer to give them a short/friendly name instead of their full long-form name. For instance, I'd like to make it Herpderp (AOL), Herpderp (RIT Gmail), and Herpderp (Outlook) so that I can easily tell them apart.

I imagine that this could go under account settings -> account, perhaps above the current field for Your Name.
Implementation note: the account name is already tracked separately ("name") and is initialized to the provided emailAddress at account creation time, although tryToCreateAccount would use an "accountName" if probided.  modifyAccount is already capable of updating this value as "name", but there is no UI surface.  However, mailapi.js' MailAccount implementation does not expect its "name" to change, so it would need to be enhanced.  So this does involve a minor back-end change (and would want test coverage like we have for other modifyAccount stuff).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

4 years ago
Well, I'm more than willing to help test out if needed.

Some possible gotchas I can think of ahead of time:
Name field needs to accept Unicode characters, diacritics, accents, etc, as well as "special" characters that aren't otherwise system reserved.
Happily, none of that should pose a problem.  Since we're just letting the user enter a string and show it back to them, other than making sure we don't do something dumb and interpret the string as HTML, we have no complications.  (Sorting is even handled by the web platform for us, although better once we have the Intl API in b2g.)

Comment 4

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.