[Stingray][Home] Apply "new folder" as well as "empty folder" behavior and visual

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rexboy, Assigned: rexboy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment)

Under edit mode,
- Pressing the new folder button should create a new folder icon on the card list.
- Moving cursor out of a new folder should remove the folder.
Blocks: 1105985
No longer blocks: 1105985
Assignee: nobody → rexboy
We found some issue on removing empty folder in CardManager. The removal wouldn't be fully functional before bug 1115295 landed, but we can still implement what we need to do on UI view, such that removing empty folder will work normally after bug 1115295 landed.
Depends on: 1115295
Created attachment 8541402 [details] [review]
Patch

Hi dwi2,
This patch includes some changes that we discussed, but since you're doing refactor works, those codes are there just for your reference.

If you're not available for reviewing this patch I can try changing it to John.
Thanks a lot!
Attachment #8541402 - Flags: review?(tzhuang)

Updated

3 years ago
Duplicate of this bug: 1076712
Comment on attachment 8541402 [details] [review]
Patch

Looks good to me. 

However there could be a lot of merge conflicts between this patch and bug 1111466. Please rebase to latest master before landing.
Attachment #8541402 - Flags: review?(tzhuang) → review+
Blocks: 1117699
https://github.com/mozilla-b2g/gaia/commit/69ac77cfa938fae2763ac426a80ca6e5feb6ad25
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Blocks: 1156143

Updated

3 years ago
Blocks: 1158665
You need to log in before you can comment on or make changes to this bug.