If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox can't update if addons installed will be incompatible in the updated version

RESOLVED DUPLICATE of bug 1100346

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1100346
3 years ago
3 years ago

People

(Reporter: cosmin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Steps:
1 Download an older version of Firefox, let's say Nightly 32:
  > ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/05/2014-05-01-03-02-02-mozilla-central/
2 Install an addon that it won't be compatible after the update:
  > https://addons.mozilla.org/en-US/firefox/addon/super-tab-mode/
3 Go to Menu > Help > About
4 Click on "Check for Updates"

Expected: Firefox will check for updates

Actual result: "Restart to Update" button will appear which does nothing




The reason we didn't caught this in our update tests is because the old Software:Update UI checks for incompatible addons and tells the user that those will be disabled.
To prompt the old UI call the function below in Error Console:
Components.classes["@mozilla.org/updates/update-prompt;1"].createInstance(Components.interfaces.nsIUpdatePrompt).checkForUpdates()
(Reporter)

Updated

3 years ago
Component: Software Update → Application Update
Product: Composer → Toolkit
Version: other → unspecified
(Reporter)

Comment 1

3 years ago
This doesn't reproduce all the time, but I can hit the issue if I open an cleanly new extracted Firefox with an profile that already has the addon.
(In reply to Cosmin Malutan from comment #0)
> Actual result: "Restart to Update" button will appear which does nothing

Do you see any failure in the browser console? This might be helpful to indicate where the problem is.

Also does Firefox update when you restart it yourself without the button?
(Reporter)

Comment 3

3 years ago
Created attachment 8530300 [details]
video.ogv

I have nothing in console, I attached an video.
This video does not show that you opened the browser console for possible js errors.
(Reporter)

Comment 5

3 years ago
This is when I open the Firefox with the addon added via mozprofile. This is what happen in our update test when I tried to check the bug 599290 with an incompatible addon. 
In console I'we get a warning that getPreventDefault is deprecated.

https://www.youtube.com/watch?v=jFWyb7jqN2o&feature=youtu.be(In reply to Cosmin Malutan from comment #3)
> Created attachment 8530300 [details]
> video.ogv
> 
> I have nothing in console, I attached an video.
I believe this is a dupe of an earlier filed bug in Firefox -> General. It also has a couple of bugs that likely regressed this. This is Firefox ui and not part of toolkit so moving to correct component.
Component: Application Update → General
Product: Toolkit → Firefox
Likely a dupe of bug 1100346
(Reporter)

Updated

3 years ago
Depends on: 1100346
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100346
You need to log in before you can comment on or make changes to this bug.