”getConfiguration: Unknown configuration requested: selectedSearchEngine UITour.jsm:1145” error is thrown in Browser Console when Firefox starts

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Assigned: agibson)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1593855])

Attachments

(1 attachment)

Reproducible on: 
Firefox 31.3.0 ESR across all platforms.

STR
1.Launch Firefox with a clean profile.
2.Open the Browser Console.

ER
No errors thrown in Browser Console.

AR
This error is thrown in Browser Console: "getConfiguration: Unknown configuration requested: selectedSearchEngine   UITour.jsm:1145".


Additional notes:
This issue is reproducible on Firefox 31.3.0 ESR (20141125031119) across Windows 7 x64, Mac OSX 10.9.5 and Ubuntu 14.04 x32 
This bug is not reproducible on Firefox 34.0.5 (20141126041045) using Windows 7 x64, Mac OSX 10.9.5 and Ubuntu 14.04 x32.
(Assignee)

Comment 1

3 years ago
I think this is just because `selectedSearchEngine` currently only exists in 34 (it's not yet on 35 or Nightly either).
(Assignee)

Comment 2

3 years ago
Additional note: this is used on /firstrun just to provide GA analytics for 34. It should not impact anything functionally.
(Assignee)

Comment 3

3 years ago
I can at least include a version check when this code is called, which would prevent the browser console error on versions < 34.
Component: General → Pages & Content
Product: Firefox → www.mozilla.org
Version: 31 Branch → Production
(Assignee)

Updated

3 years ago
Whiteboard: [kb=1593855]
(Assignee)

Updated

3 years ago
Assignee: nobody → agibson
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
Created attachment 8530546 [details] [review]
GitHub pull request

Comment 5

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/c6d178bab5fee1ded46032a7080e8441bdc0c66f
[fix bug 1106065] Add version check for getConfiguration('selectedSearchEngine') on firstrun

https://github.com/mozilla/bedrock/commit/6ef2b28a547322132e381204289e69b62b644abc
Merge pull request #2554 from alexgibson/add-version-check-firstrun

[fix bug 1106065] Add version check for getConfiguration('selectedSearchEngine') on firstrun

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.