overall slower performance when another application is running

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Giovanni Gatti, Assigned: asa)

Tracking

({perf})

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I get a very slow performance of Mozilla (do you remember 0.6?) when I start
another application like Appleworks 6.2 or iTunes.

My build is 0.9.5 milestone, I run OS X 10.1.1 on a Powerbook G3 Lombard with
192 mb ram.

The slowness is when I type and when I move through windows ans messages. Very
slow. It appears the colored disc instead of the clock, and the user has to wait.

It is such a pain in the neck...

If I quit the other application, Mozilla comes back to behave quite good.

Comment 1

17 years ago
I would agree, to a point. If you run top and monitor Mozillas CPU usage, you
may notice that it ‘s starting to get greedy. Starting up Mozilla with no
windows your around 4-5% run the browser buster test for 5-10 minutes watch the
CPU usage grow. After 5-10 minutes close all browser windows and watch as the
CPU usage slowly decline.

So I think the problem is just that Mozilla tends to be more CPU greedy right now.
(Reporter)

Comment 2

17 years ago
well, I verified this. I tested with Internet Explorer running: no problems.
With Appleworks 6.2 running: big problems, it sucks more than 30% CPU time and
poor Mozilla suffers this. Again the same with iTunes up and playing streaming
audio. 

It seems that Apple software sucks a lot of cpu power. Bad engineering?

This is really awful.

So maybe Mozilla just does as much as it can, due the overall situation of my
machine...

Updated

17 years ago
Keywords: perf
(Reporter)

Comment 4

17 years ago
well, much better with 2001111609.

Anyway the colored rotating disk appears anytime I move through folders in
Mail/News and when I do other operations like moving messages etc.

But now I can use it.

It happens that I cannot edit the Message filters. Should I redescribe them anew?
Marking WFM for this bug. 

Giovanni: You should file a separate bug for other issues:
http://www.mozilla.org/quality/help/bugzilla-helper.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.