If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mach build failure - autoconf213

RESOLVED INVALID

Status

()

Core
mach
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Vinay, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36

Steps to reproduce:

./mach bootstrap


Actual results:

Vinays-MBP:mozilla-central Vinay$ ./mach bootstrap

Looks like you have Homebrew installed. We will install all required packages via Homebrew.


We are now installing all required packages via Homebrew. You will see a lot of
output as packages are built.

Homebrew 0.9.5
/usr/bin/curl -fLA Homebrew 0.9.5 (Ruby 2.0.0-481; Mac OS X 10.10.1) https://raw.github.com/Homebrew/homebrew-versions/master/autoconf213.rb -o /Library/Caches/Homebrew/Formula/autoconf213.rb
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   634  100   634    0     0    864      0 --:--:-- --:--:-- --:--:--   864
==> Downloading http://ftpmirror.gnu.org/autoconf/autoconf-2.13.tar.gz
Already downloaded: /Library/Caches/Homebrew/autoconf213-2.13.tar.gz
==> Verifying autoconf213-2.13.tar.gz checksum
tar xf /Library/Caches/Homebrew/autoconf213-2.13.tar.gz
==> ./configure --disable-debug --disable-dependency-tracking --program-suffix=213 --prefix=/usr/local/Cellar/autoconf213/2.13 --infodir=/usr/local/Cellar/autoconf213/2.13/share/info --datadir=/usr/local/Cellar/autoconf213/2.13/share/autoconf213
creating cache ./config.cache
checking for gm4... /usr/bin/gm4
checking for mawk... no
checking for gawk... no
checking for nawk... no
checking for awk... awk
checking for perl... /usr/bin/perl
checking for a BSD compatible install... /usr/bin/install -c
updating cache ./config.cache
creating ./config.status
creating Makefile
creating testsuite/Makefile
==> make install
rm -f autoconf autoconf.tmp
rm -f autoheader autoheader.tmp
rm -f autoreconf autoreconf.tmp
sed -e 's,@''datadir''@,/usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf,g' -e 's,@''M4''@,/usr/bin/gm4,g'  -e 's,@''AWK''@,awk,g' -e 's,@''SHELL''@,/bin/sh,g' autoconf.sh > autoconf.tmp && chmod +x autoconf.tmp && mv autoconf.tmp autoconf
sed -e 's,@''datadir''@,/usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf,g' -e 's,@''M4''@,/usr/bin/gm4,g'  -e 's,@''AWK''@,awk,g' -e 's,@''SHELL''@,/bin/sh,g' autoheader.sh > autoheader.tmp && chmod +x autoheader.tmp && mv autoheader.tmp autoheader
rm -f autoupdate autoupdate.tmp
sed -e 's,@''datadir''@,/usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf,g' -e 's,@''M4''@,/usr/bin/gm4,g'  -e 's,@''AWK''@,awk,g' -e 's,@''SHELL''@,/bin/sh,g' autoreconf.sh > autoreconf.tmp && chmod +x autoreconf.tmp && mv autoreconf.tmp autoreconf
sed -e 's,@''datadir''@,/usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf,g' -e 's,@''M4''@,/usr/bin/gm4,g'  -e 's,@''AWK''@,awk,g' -e 's,@''SHELL''@,/bin/sh,g' autoupdate.sh > autoupdate.tmp && chmod +x autoupdate.tmp && mv autoupdate.tmp autoupdate
rm -f ifnames ifnames.tmp
rm -f autoscan autoscan.tmp
sed -e 's,@''datadir''@,/usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf,g' -e 's,@''PERL''@,/usr/bin/perl,g' autoscan.pl > autoscan.tmp && chmod +x autoscan.tmp && mv autoscan.tmp autoscan
sed -e 's,@''datadir''@,/usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf,g' -e 's,@''M4''@,/usr/bin/gm4,g'  -e 's,@''AWK''@,awk,g' -e 's,@''SHELL''@,/bin/sh,g' ifnames.sh > ifnames.tmp && chmod +x ifnames.tmp && mv ifnames.tmp ifnames
/bin/sh ./mkinstalldirs /usr/local/Cellar/autoconf213/2.13/bin /usr/local/Cellar/autoconf213/2.13/share/info /usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf
mkdir /usr/local/Cellar/autoconf213/2.13/bin
mkdir /usr/local/Cellar/autoconf213/2.13/share
mkdir /usr/local/Cellar/autoconf213/2.13/share/info
mkdir /usr/local/Cellar/autoconf213/2.13/share/autoconf213
mkdir /usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf
if test -f autoconf.info; then \
	  for i in *.info*; do \
	    /usr/bin/install -c -m 644 $i /usr/local/Cellar/autoconf213/2.13/share/info/$i; \
	  done; \
	else \
	  for i in ./*.info*; do \
	    /usr/bin/install -c -m 644 $i /usr/local/Cellar/autoconf213/2.13/share/info/`echo $i | sed 's|^./||'`; \
	  done; \
	fi
freezing autoheader.m4
freezing autoconf.m4
for p in autoconf autoheader autoreconf autoupdate ifnames ; do \
	  /usr/bin/install -c $p /usr/local/Cellar/autoconf213/2.13/bin/`echo $p|sed 's,$,213,; '`; \
	done
for i in autoconf.m4f autoheader.m4f; do \
	  /usr/bin/install -c -m 644 $i /usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf/$i; \
	done
for i in autoconf.m4 acgeneral.m4 acoldnames.m4 acspecific.m4 autoheader.m4 acconfig.h; do \
	  /usr/bin/install -c -m 644 ./$i /usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf/$i; \
	done
if test -f autoscan; then \
	/usr/bin/install -c autoscan /usr/local/Cellar/autoconf213/2.13/bin/`echo autoscan|sed 's,$,213,; '`; \
	for i in acfunctions acheaders acidentifiers acprograms \
	  acmakevars; do \
	/usr/bin/install -c -m 644 ./$i /usr/local/Cellar/autoconf213/2.13/share/autoconf213/autoconf/$i; \
	done; \
	else :; fi
==> Cleaning
==> Finishing up
ln -s ../Cellar/autoconf213/2.13/bin/autoconf213 autoconf213
ln -s ../Cellar/autoconf213/2.13/bin/autoheader213 autoheader213
ln -s ../Cellar/autoconf213/2.13/bin/autoreconf213 autoreconf213
ln -s ../Cellar/autoconf213/2.13/bin/autoscan213 autoscan213
ln -s ../Cellar/autoconf213/2.13/bin/autoupdate213 autoupdate213
ln -s ../Cellar/autoconf213/2.13/bin/ifnames213 ifnames213
ln -s ../Cellar/autoconf213/2.13/share/autoconf213 autoconf213
rm /usr/local/bin/autoconf213
rm /usr/local/bin/autoheader213
rm /usr/local/bin/autoreconf213
rm /usr/local/bin/autoscan213
rm /usr/local/bin/autoupdate213
rm /usr/local/bin/ifnames213
rm /usr/local/share/autoconf213
Error: The `brew link` step did not complete successfully
The formula built, but is not symlinked into /usr/local
Could not symlink share/info/autoconf.info
/usr/local/share/info is not writable.

You can try again using:
  brew link autoconf213
==> Summary

Comment 1

3 years ago
tbh, this looks to me like there's a homebrew problem. That's not something mach can fix for you.
Component: Untriaged → mach
Product: Firefox → Core

Comment 2

3 years ago
It looks like your Homebrew installation isn't proper. I suggest running `brew doctor` and take any corrective actions it recommends.
Flags: needinfo?(vmm)
(Reporter)

Comment 3

3 years ago
Thanks. Turned out autoconf was not linked by brew.
Flags: needinfo?(vmm)
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.