IndexedDB Transaction warning in Cost Control

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Cost Control
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: gerard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I do see this quite constantly on my Nexus S, running master.

> 11-28 16:03:55.304   730   730 W Usage   : [JavaScript Warning: "An IndexedDB transaction that was not yet complete has been aborted due to page navigation." {file: "app://costcontrol.gaiamobile.org/gaia_build_message_handler.js" line: 220}]

STR:
 0. Send a SMS

Expected:
 No warning on logcat

Actual:
 This warning is displayed in logcat.
Flags: needinfo?(marina.rodriguez.iglesias)
(Reporter)

Comment 1

3 years ago
Ben, do you think this may be bad for IDB ?
Flags: needinfo?(bent.mozilla)
(Reporter)

Updated

3 years ago
blocking-b2g: --- → 2.2?
(Reporter)

Comment 2

3 years ago
FYI, Johann on a fresh profile does not reproduce. So this may be because of the amount of data I have ?
Hi Alexandre,
costcontrol app has a counter for the sent messages, the App is launched in background when a message is sent. Maybe when the profile is not fresh, the App consume more memory and the oom killer kills the costcontrol app before the updating operation has ended. 
WDYT?
Regards
Flags: needinfo?(marina.rodriguez.iglesias)
(Reporter)

Comment 4

3 years ago
(In reply to Marina Rodríguez [:mai] from comment #3)
> Hi Alexandre,
> costcontrol app has a counter for the sent messages, the App is launched in
> background when a message is sent. Maybe when the profile is not fresh, the
> App consume more memory and the oom killer kills the costcontrol app before
> the updating operation has ended. 
> WDYT?
> Regards

No, I don't think it's related to being OOM killed, I don't see it in the logs. If you need some database from my phone to be able to investigate, just ask :)
Flags: needinfo?(marina.rodriguez.iglesias)
(Reporter)

Comment 5

3 years ago
I'm starting to see it in other places too, so it may not be because of Cost Control.
triage: per comment 5 I'm changing component to "general" for now.
Component: Gaia::Cost Control → General
Flags: needinfo?(marina.rodriguez.iglesias)
Flags: needinfo?(bent.mozilla)
Component: General → Gaia::Cost Control
Triage: we don't know if it can be reproduced, and not affecting user.

Alexandre are you still seeing this problem?
blocking-b2g: 2.2? → ---
Flags: needinfo?(lissyx+mozillians)
(Reporter)

Comment 8

3 years ago
Yes I still see this, but last time I spoke about this with :bent he told me it was probably nothing grave.
Flags: needinfo?(lissyx+mozillians)
Well, not grave, but it may mean that cost control data we're trying to save gets tossed out instead of actually saved...
(Reporter)

Comment 10

3 years ago
Francisco, from the logs on my Nexus S build of today (master):
> 02-07 12:46:14.089   416   416 W Usage   : [JavaScript Warning: "An IndexedDB transaction that was not yet complete has been aborted due to page navigation." {file: "app://costcontrol.gaiamobile.org/gaia_build_message_handler.js" line: 231}]

Comment 11

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.