The default bug view has changed. See this FAQ.

MediaCodec error; only audio when playing mp4s on Aurora on particular devices

RESOLVED WONTFIX

Status

()

Firefox for Android
Audio/Video
RESOLVED WONTFIX
2 years ago
8 months ago

People

(Reporter: u421692, Assigned: snorp)

Tracking

35 Branch
All
Android
Points:
---

Firefox Tracking Flags

(firefox34 unaffected, firefox35? wontfix, firefox36 unaffected, fennec+)

Details

Attachments

(1 attachment)

50.67 KB, application/zip
Details
(Reporter)

Description

2 years ago
Created attachment 8530328 [details]
logs.zip

Device: Alcatel One Touch 8008D (Android 4.1.2)
Build: Aurora 35.0a2 (2014-11-28)

Steps to reproduce:
1. Open http://people.mozilla.org/~atrain/mobile/tests/media.html
2. Tap to play on a mp4 video

Expected result:
Video is played without any issues

Actual result:
No video is played, only audio

Note:
I was only able to reproduce this issue on an Alcatel One Touch 8008D, and only on Aurora

From logcat:
11-28 15:31:08.267: E/ACodec(7476): [OMX.MTK.VIDEO.DECODER.AVC] ERROR(0x80001005)
11-28 15:31:08.267: E/MediaCodec(7476): Codec reported an error. (omx error 0x80001005, internalError -2147483648)

11-28 15:10:11.915: E/OMXNodeInstance(130): OMX_GetExtensionIndex failed

Updated

2 years ago
Assignee: nobody → snorp
Blocks: 1014614
Status: NEW → ASSIGNED
tracking-fennec: --- → ?
Can you retry this? Some changes went into Aurora.
Flags: needinfo?(mihai.g.pop)
tracking-fennec: ? → +
(Reporter)

Comment 2

2 years ago
I am unable to reproduce this issue anymore on Alcatel One Touch 8008D(Android 4.1.2), on latest Aurora.
Flags: needinfo?(mihai.g.pop)
(Reporter)

Comment 3

2 years ago
It seems that unfortunately, Firefox 35 Beta 1 and Firefox 35 Beta 2 are affected now.
I was only able to reproduce this issue on this particular device, don't know how many users might be affected by this problem.
Ok, this was likely fixed by bug 1097116 then, which is not on Beta. I think we're just going to let that ride the trains, it seems to only affect a few devices, and we still need another fix for PowerVR variants.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

2 years ago
See also Bug 1110819
http://www.gsmarena.com/compare.php3?idPhone1=5671&idPhone2=5218
[Tracking Requested - why for this release]:

I think this should be marked WONTFIX since this is *not* going to be fixed in 35 Beta (based on comment 3). Nominating to track so this is on our radar in case Beta feedback tells us this is a bigger issue.
status-firefox35: affected → wontfix
tracking-firefox35: --- → ?
Resolution: FIXED → WONTFIX
You need to log in before you can comment on or make changes to this bug.