"Redeclaration of var ..." TypeError message should include location of the first declaration

RESOLVED DUPLICATE of bug 104442

Status

()

RESOLVED DUPLICATE of bug 104442
4 years ago
4 years ago

People

(Reporter: fitzgen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I'm getting this message:

  TypeError: redeclaration of var parent at /Users/fitzgen/src/mozilla-central-opt/obj.noindex/_tests/xpcshell/toolkit/devtools/tests/unit/test_RedBlackTree.js:8

And it is really frustrating because I can't for my life find the first declaration of `parent`. It would be *really* nice if the message included this information.
I'm going to work on this after some Parser/TokenStream cleanup in bug 1089045.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 104442
You need to log in before you can comment on or make changes to this bug.