mozharness mach builds can't accecpt unicode chars in src commit messages

RESOLVED DUPLICATE of bug 1146035

Status

defect
RESOLVED DUPLICATE of bug 1146035
5 years ago
4 years ago

People

(Reporter: jlund, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=53816507&full=1&branch=mozilla-inbound

I think attached patch should fix the issue. I was going to try encoding correctly at the message assignment, but it looks like the issue is actually when we set that as a buildbot property and persist to file.

I think this patch is better as it improves the versatility of write_to_file and could protect us from many different entry points to it.


I'd try this on cypress before putting to prod.
Attachment #8530579 - Flags: review?(catlee)
Component: General Automation → Mozharness
QA Contact: catlee → jlund
Comment on attachment 8530579 [details] [diff] [review]
141129_mh_mach_on_trunk-fix-unicode-in-src-commit.patch

Review of attachment 8530579 [details] [diff] [review]:
-----------------------------------------------------------------

I think this is very likely to cause fallout now, or in the future. We can't always assume we're going to be dealing with UTF-8 encoded data. Perhaps add an encoding parameter to this method, or explicitly encode the property before we write it out.
Attachment #8530579 - Flags: review?(catlee) → review-
Blocks: 1055912
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146035
You need to log in before you can comment on or make changes to this bug.