[e10s] Context Menu does not work properly, Hovering menuitem highlight is broken and command does not execute unless I click context menu once

VERIFIED WORKSFORME

Status

()

Core
Event Handling
P1
normal
VERIFIED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({platform-parity, ux-consistency})

Trunk
x86_64
Linux
platform-parity, ux-consistency
Points:
---

Firefox Tracking Flags

(firefox48 verified, firefox49 verified, firefox50 verified)

Details

(Reporter)

Description

4 years ago
In e10s window on Linux,
Context Menu does not work properly.
Hovering menuitem highlight is broken and command does not execute unless I click context menu once.

Reproducible: Always

Steps to Reproduce:
1. Start Nightly with new profile and e10s is enabled
2. Right mouse down on contents area (do not mouse up)
3. Mouse hover the context menu item
   --- Hovering menuitem highlight is broken
4. Mouse up on a menuitem to execute command
   --- No thing happens

Actual Results:
 Hovering menuitem highlight is broken and command does not execute unless I click context menu once
 In other words, the actual behavior is of windows.

Expected Results:
 Hovering menuitem highlight and command should be performed properly.
 The behavior should be of normal Linux application as well as non-e10 windows of Nightly.
(Reporter)

Updated

4 years ago
Keywords: ux-consistency
(Reporter)

Updated

4 years ago
Summary: Context Menu does not work properly, Hovering menuitem highlight is broken and command does not execute unless I click context menu once → [e10s] Context Menu does not work properly, Hovering menuitem highlight is broken and command does not execute unless I click context menu once
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1108239

Comment 2

4 years ago
(In reply to Alice0775 White from comment #0)
> In e10s window on Linux,
> Context Menu does not work properly.
> Hovering menuitem highlight is broken and command does not execute unless I
> click context menu once.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Start Nightly with new profile and e10s is enabled
> 2. Right mouse down on contents area (do not mouse up)

Trying to reproduce on win76, I don't get a menu without a mouse up message though?
(Reporter)

Comment 3

4 years ago
(In reply to Jim Mathies [:jimm] from comment #2)
> (In reply to Alice0775 White from comment #0)
> > In e10s window on Linux,
> > Context Menu does not work properly.
> > Hovering menuitem highlight is broken and command does not execute unless I
> > click context menu once.
> > 
> > Reproducible: Always
> > 
> > Steps to Reproduce:
> > 1. Start Nightly with new profile and e10s is enabled
> > 2. Right mouse down on contents area (do not mouse up)
> 
> Trying to reproduce on win76, I don't get a menu without a mouse up message
> though?

This bug is for Linux.
(Reporter)

Updated

4 years ago
Keywords: pp
e10s UI polish
tracking-e10s: ? → m8+

Comment 5

4 years ago
Re-enabled e10s by default on Firefox 38 now because of bug 119734 fix.
I think we need to fix this bug before Firefox 38 releases.

Updated

3 years ago
Duplicate of this bug: 1068643
tracking-e10s: m8+ → +

Comment 7

3 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID 	20160207030402

This still reproduces on latest Aurora (46.0a2) and latest Nightly (47.0a1). Tested on Ubuntu 15.04.
Priority: -- → P1

Comment 8

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160707004018

Can't reproduce with aurora 49.0a2 on arch linux (gtk 3.20.6)

Comment 9

2 years ago
(In reply to dx from comment #8)
> User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101
> Firefox/49.0
> Build ID: 20160707004018
> 
> Can't reproduce with aurora 49.0a2 on arch linux (gtk 3.20.6)

I also cannot reproduce with recent nightly build on Debian unstable. (gtk 3.20.6)
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
tracking-e10s: + → ---
Resolution: --- → WORKSFORME
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
status-firefox48: --- → verified
status-firefox49: --- → verified
status-firefox50: --- → verified

Comment 10

2 years ago
For reference, this was fixed by 1251634.
You need to log in before you can comment on or make changes to this bug.