Fonts of menus are enlarged in Japanese mode

RESOLVED FIXED

Status

()

RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: tetsuji.rai, Assigned: tetsuroy)

Tracking

({intl})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011118
BuildID:    all on Linux

When "LANG=ja_JP" is set, fonts of menus are enlarged.  This happens all
versions of Mozilla on Linux regardless of the homepage you look at.  Even in
English page.  Sometimes fonts in a homepage are enlarged, which is shown in the
URL above.  I don't mean I want Japanese menus.   I just want fonts in the menus
to stay the same size.   This environment variable is necessary to enter
Japanese characters; ie when writing Japanese email, etc.
  This setting cannot be changed by "preferenece" menu.


Reproducible: Always
Steps to Reproduce:
1.invoke mozilla with the environment variable LANG set to ja_JP
This is necessary to input Japanese characters, not to display Japanese characters.


Actual Results:  All fonts in menus are enlarged, and some fonts in homepages
are enlarged.

Expected Results:  Size of fonts are the same as in English mode.
This is most likely due to the following lines in unix.js:

pref("font.min-size.variable.ja", 16);
pref("font.min-size.fixed.ja", 16);
(Reporter)

Comment 2

17 years ago
Hmmm...it didn't work for me.....
(Reporter)

Comment 3

17 years ago
I tried once more and it partially worked; fonts in the homepage are correct,
however, fonts in the menus are a little bigger.....may need some adjustment,
but acceptable to me.
My setting is:

pref("font.size.variable.ja", 10);
pref("font.size.fixed.ja", 10);

Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
did the recent checkins for bug 90813 solve this?

Updated

17 years ago
Keywords: intl
QA Contact: teruko → ylong
(Reporter)

Comment 5

17 years ago
I checked now and found it was fixed.
Thanks.
You need to log in before you can comment on or make changes to this bug.