Change search input placeholder when tab is changed

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Music
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: bytecode3m, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141127004008

Steps to reproduce:

For example when we are Albums tab, the search placeholder is still "Search Music" but we cannot search a song name with it since results can only be album names. So I added a function named updateSearchInputPlaceholder to mode_manager.js. The function is similar to updateTitle except it updates placeholders according to which tab is on and then called the function from _updateMode after updateTitle. After that I added three extra attributes named search-artist, search-album and search-song which are called from the function I created to locales. I translated them using Google Translate.


Actual results:

Results seems to be okay.


Expected results:

Expected result.

Updated

3 years ago
Duplicate of this bug: 1106442

Comment 2

5 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.