Callek's SSH keys are no longer accepting for hg.m.o logins

RESOLVED FIXED

Status

Infrastructure & Operations Graveyard
Account Requests
--
major
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Callek, Assigned: jabba)

Tracking

Details

(Reporter)

Description

4 years ago
So in IRC a few days ago I was told there was case normalization going on with ssh key stuff.

jwood@PERSEUS /c/Sources/hg/puppet
$ ssh -i ~/.ssh/id_rsa callek@gmail.com@hg.mozilla.org
No interactive shells allowed here!
Connection to hg.mozilla.org closed.

jwood@PERSEUS /c/Sources/hg/puppet
$ ssh -i ~/.ssh/id_rsa Callek@gmail.com@hg.mozilla.org
Permission denied (publickey).

I explicitly have everything for my community setup with Callek@gmail.com, and the latter still works for LDAP logins, just not ssh-based logins, please correct ASAP. (I need to accomplish some work before I board my plane in a few hours)
Assignee: server-ops → achavez
Assignee: achavez → jdow
Unless there is a dire emergency for this account to make pushes we'll fix this tomorrow.  I'm guessing by your irc name of Callek_disconnected that you aren't around right now anyway
(Reporter)

Comment 2

4 years ago
Joining IRC now and pinging to clarify, but to be clear, i wanted to do some pushes at ~6am ET (3am PT).

I can push-off to about 3pm PT, but it my timing by a bit.

I wouldn't call this a "dire emergency" state of a push, even if not done tomorrow at all, just to clarify. [sorry on the blocker status, I didn't mean to set it higher than major - and yea I *should* be responding in IRC when setting a blocking bug]
Severity: blocker → major
(Reporter)

Comment 3

4 years ago
See-Also, recent bug: Bug 1103089
(Assignee)

Comment 4

4 years ago
I changed callek@gmail.com back to Callek@gmail.com in LDAP. This breaks some google list sync stuff (causes unnecessary noise in the reports), but since hg is using mail-as-posix-username, I suppose we'll have to deal with this brokenness. Confirmed on IRC that Callek is unbroken.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
just out of curiosity, why 2 hg accounts?   jwood@mozilla.com is also one with access.
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.