[FFOS2.0]Russian encodings support for mediafiles titles and details

RESOLVED DUPLICATE of bug 850520

Status

P2
normal
RESOLVED DUPLICATE of bug 850520
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #96101 +++
 DEFECT DESCRIPTION: MP3 with Russian titles and tags look like empty squares
 
 REPRODUCING PROCEDURES:
 1. Load some mp3 with Russian titles/tags (see attached rar file "Russian
 mp3").
 2. View songs list in two part of phone:
   1)Mediaalbum
   2) Music player
 3. Find that:
  - in Medialbum songs's titles look OK, but tags are unreadable ( songs
 details): see attached "1.Media-album_song_list.jpg";
  -  in Music player both titles and tags are unreadable: see attached
 "2.Music_player_songs_list.jpg".
 
 Important notice: all mentioned attachenments you can find in PR 76448
 
 EXPECTED BEHAVIOUR: We need to have Russian encodings ( Windows-1251, UTF-8,
 KOI8-R) supported for Russian mp3s titles and tags in both parts: Mediaalbum
 and Musiaplayer.
 
 
 The same issue was raised in  forllowing PRs:
 
 56503 - for OT-980;
 76448 - for OT-799
 87529 - for OT-890
 
 So we face the same issue in each product, please implement this REQ in all following products for Russia.
 ++++++++++ end of initial bug #96101 description ++++++++++
 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 850520
You need to log in before you can comment on or make changes to this bug.