[Flame][Video]Video crashed.

RESOLVED DUPLICATE of bug 1101826

Status

--
major
RESOLVED DUPLICATE of bug 1101826
4 years ago
4 years ago

People

(Reporter: huayu.li, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8530830 [details]
logcat.txt

[1.Description]:
[Flame][2.1][Video]Video crashed after playing 10 videos.

Title:B2G 34.0 Crash Report [@ mozalloc_abort(char const*) | __android_log_assert | android::OMXCodec::onCmdComplete(OMX_COMMANDTYPE, unsigned long) ]

Link:https://crash-stats.mozilla.com/report/index/729dd847-f532-4590-856f-809322141201

Occurence time:15:58
Attachments:logcat.txt,figure 1.png.

[2.Testing Steps]: 
1.Load 20 HD video on device.
2.Launch video.
3.Play the first video.
4.After playing complete,back to video list and play next video.
5.Repeat 4 for other video.

[3.Expected Result]: 
5.Video should be played.

[4.Actual Result]: 
5.While playing 10 video,video crash.

[5.Reproduction build]: 
Flame 2.1 new versions:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0


[6.Reproduction Frequency]: 
Once,1/2
TCID:Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8530831 [details]
2014-12-01-15-58-16.png
(Reporter)

Updated

4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → unaffected
In attachment 8530830 [details], the following log exist. From it, this bug seems dup of Bug 1101826.

> 12-01 15:58:00.260 F/OMXCodec( 1414): frameworks/av/media/libstagefright/OMXCodec.cpp:2804 CHECK_EQ( countBuffersWeOwn(mPortBuffers[portIndex]),mPortBuffers[portIndex].size()) failed: 3 vs. 4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1101826
You need to log in before you can comment on or make changes to this bug.