Closed Bug 1106529 Opened 5 years ago Closed 5 years ago

Thunderbird blocks (freezes) with following ics

Categories

(Calendar :: General, defect)

Lightning 3.3
Other
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 875739

People

(Reporter: daniel.becker, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141106120505

Steps to reproduce:

Attached calendar ICS file causes thunderbird to freeze forever. It was possibly generated by outlook as I was invited to this appointment.
This appointment was part of a caldav sync with owncloud containing over 1.800 entries.

However the error is reproducable by just adding this file as a new calendar. So it is not the caldav connector, ssl socket or else - just the ics-file itself.


Actual results:

Thunderbird blocks completely. No error message in the error console is displayed.
The error occurses with Lightning 3.3.1, 3.3.1.2, 3.3.2 with Thunderbird 31.2.0 on Windows 7 and on Windows XP, German locale.

If adding the enclosed ICS-File to Thunderbird it will hang instantly. You need to rename the file to make Thunderbird work again after killing and restarting. Otherwise - if not renamed - Thunderbird will never come up again.


Expected results:

Whatever the cause for this hang is - thunderbird should produce an error and direct to the conflicting appointment in the error console - but never freeze completely with CPU at 100% (or 25% on quadcore).

I assume that it might be the UTF-8 characters producing this error.
OS: All → Windows 7
Hardware: All → Other
BEGIN:VEVENT
CREATED:20141017T065758Z
PRIORITY:5
ORGANIZER;CN= Iris;CN=Becker\\:mailto:some@mailadress.de
ATTENDEE;PARTSTAT=DECLINED;CN='Daniel Becker';RSVP=TRUE;ROLE=REQ-PARTICIPAN


There are two CN parameters in the organizer so it should be a duplicate of Bug 875739.
Removing either the first or the second parameter, the calendar doesn't freeze Thunderbird.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875739
You need to log in before you can comment on or make changes to this bug.