When deleting a Room in Firefox Hello Desktop, the Room is not removed from the Conversation list

VERIFIED FIXED in Firefox 35

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: oteo, Assigned: standard8)

Tracking

({regression})

unspecified
mozilla37
Points:
1
Dependency tree / graph
Bug Flags:
in-testsuite +
qe-verify -

Firefox Tracking Flags

(firefox35? fixed, firefox36 fixed, firefox37 fixed)

Details

Attachments

(1 attachment)

After removing a Room from the Conversation list in Firefox Hello application and confirming the action, the user can not join the Room anymore but the Room entry is not removed from the conversation list
Ok, this is a regression, sort-of, as we're relying on version 0.14 of the server that isn't out yet.

We're also relying on push notifications to get us the update for the local user.

I think I know what to do to restore this - its something I took out in bug 1089722 but wasn't 100% sure if we wanted to keep it or not at the time.
Assignee: nobody → standard8
Blocks: 1089722
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All
backlog: --- → Fx35+
Priority: -- → P1
[Tracking Requested - why for this release]:
We need this fix for the first release of Rooms
Duplicate of this bug: 1106981
Duplicate of this bug: 1107090
This puts the event back in that bug 1089722 removed. It does mean we effectively get double-delete events, but we handle it correctly, even if the server fails to give us a push notification afterwards (and there's quicker user feedback).
Attachment #8531666 - Flags: review?(nperriault)
Comment on attachment 8531666 [details] [diff] [review]
When deleting a room, the room is not removed from the conversation list - add a notification of the delete completing.

Review of attachment 8531666 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.

::: browser/components/loop/test/xpcshell/test_looprooms.js
@@ +396,5 @@
>  
> +// Test if deleting a room works as expected.
> +add_task(function* test_deleteRoom() {
> +  let roomToken = "QzBbvGmIZWU";
> +  gExpectedDeletes.push("QzBbvGmIZWU");

Nit: How about gExpectedDeletes.push(roomToken)?
Attachment #8531666 - Flags: review?(nperriault) → review+
https://hg.mozilla.org/integration/fx-team/rev/42ce3ca2e600
Iteration: --- → 37.1
Points: --- → 1
Target Milestone: --- → mozilla37
https://hg.mozilla.org/mozilla-central/rev/42ce3ca2e600
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1108010
Duplicate of this bug: 1108422
Comment on attachment 8531666 [details] [diff] [review]
When deleting a room, the room is not removed from the conversation list - add a notification of the delete completing.

Approval Request Comment
[Feature/regressing bug #]: bug 1089722
Landed on m-c right before uplift to aurora

[User impact if declined]: broken delete behavior on Aurora, no user confirmation of delete (blocks bug 1092953)

[Describe test coverage new/current, TBPL]: On m-c and tested by me both on m-c and with the delete code

[Risks and why]: Very simple and simply undoes some stuff removed in bug 1089722 (so we're not dependent on an unreleased version of the server).

[String/UUID change made/needed]: none
Attachment #8531666 - Flags: approval-mozilla-beta?
Attachment #8531666 - Flags: approval-mozilla-aurora?
Attachment #8531666 - Flags: approval-mozilla-beta?
Attachment #8531666 - Flags: approval-mozilla-beta+
Attachment #8531666 - Flags: approval-mozilla-aurora?
Attachment #8531666 - Flags: approval-mozilla-aurora+
tested extensively on linux64
Maria, this should be fixed in the latest Nightly, Aurora, and Beta builds.
Flags: qe-verify-
Flags: needinfo?(oteo)
yes, it's working fine! Thanks a lot Anthony
Flags: needinfo?(oteo)
Thank you, Maria.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.