browser crash while saving redirected image

VERIFIED DUPLICATE of bug 102936

Status

()

--
critical
VERIFIED DUPLICATE of bug 102936
17 years ago
17 years ago

People

(Reporter: nalp, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001101117

If you try to save an image (that is embedded in an html document) with the
"save image" function and the server returns an redirect error (permanent (301)
or temp (302) ) the browser reports the error:
"There was an error while reading from the source location." 
and crashs immediately. In the html page itself the image is shown normally.


Reproducible: Always
Steps to Reproduce:
1. Setup a redirect on your webserver. 
For example with apache:
"Redirect permanent /bug http://redirect.aim/try"
2.Create http://redirect.aim/try/picture.jpg 
3.Create an html Document with <img src="/bug/picture.jpg">
4.Open the Document with Mozilla and try "Save Image".


Actual Results:  First the Error: "There was an error while reading from the
source location."
and then after an "enter" follows a  Crash.

Expected Results:  Should save the image on the disk.

I tried to reproduce the error with  Mozilla 0.9.4 (Build ID: 2001091303 the one
i post this bug with). This version handles the image correctly.

Windows Error Message:
Dieser Vorgang wird aufgrund eines ungültigen Vorgangs geschlossen.
Wenden sie sich an den Hersteller, falls das Problem weiterhin besteht.

MOZILLA verursachte einen Fehler durch eine ungültige Seite
in Modul MOZXFER.DLL bei 0167:606b24a1.
Register:
EAX=00000000 CS=0167 EIP=606b24a1 EFLGS=00010246
EBX=00000000 SS=016f ESP=0068fa6c EBP=60e62bf0
ECX=00000000 DS=016f ESI=01d4dbec FS=194f
EDX=606b32b0 ES=016f EDI=01d4dbdc GS=1937
Bytes bei CS:EIP:
8b 08 53 50 ff 51 1c 8b d8 f7 c3 00 00 00 80 74 
Stapelwerte:
ffffffff 00000000 01d4dbec 022321a4 02232110 02233974 6086028c 01d4dbdc 02232110
00000000 6086c690 02233450 60e62b60 6083e7b5 02232114 02233974

Comment 1

17 years ago
WFM Win98 2001111603 - could you try to duplicate this problem with a more
recent build?  The one you're (apparently) reporting on is 2001101117, more than
a month old.

Marking as dupe of bug 102936.

Reporter: 0.9.5 is old. Please try a more recent build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
(as always, be sure to delete your old Mozilla directory before installing the
new one)

-> Networking: HTTP, for parity with dupe

*** This bug has been marked as a duplicate of 102936 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Browser-General → Networking: HTTP
Keywords: crash
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Known problem, has been fixed for a long time ---> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.