[FTU] There is a slight delay when the text appears on the language screen

RESOLVED DUPLICATE of bug 1173145

Status

Firefox OS
Gaia::First Time Experience
RESOLVED DUPLICATE of bug 1173145
4 years ago
3 years ago

People

(Reporter: Petes, Assigned: sfoster)

Tracking

({regression})

unspecified
FxOS-S5 (21Aug)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-exploratory-1] , URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8530918 [details]
ft.txt

Description:
When flashing or factory reset, there is a slight delay when the text appears on the language screen 
  
Repro Steps:
1) Update a Flame device to BuildID: 20141201040205
2) Flash to the latest master or factory reset 
3) Observe the language screen 

  
Actual:
slight delay when the text appears on the language screen 
  
Expected: 
no delay
  
Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (Unknown)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

  
Repro frequency: 3/3, 100%
See attached: video, logcat, https://www.youtube.com/watch?v=nfv4WzNWj8E
(Reporter)

Comment 1

4 years ago
This issue does not reproduce on the Flame 2.1, no delay on language screen.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Not nominating to block on this. This only occurs when the language page is first loaded after a fresh flash or reset. If the user goes forwards, and then backwards to the language page again, performance is normal.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 3

3 years ago
This is an ugly performance indicator on first run. Can we take another look at prioritizing this? Also, is this the same as bug 1173145?
(Assignee)

Comment 4

3 years ago
Leaving need-info on myself to look into this once I have a local build again and the ability to profile it
Flags: needinfo?(sfoster)
(Assignee)

Comment 5

3 years ago
Have a WIP that seems to help here, but I want to get user timing instrumentation in there first so we have a baseline to compare to.
Assignee: nobody → sfoster
Depends on: 1193369
Flags: needinfo?(sfoster)
Target Milestone: --- → FxOS-S5 (21Aug)
(Assignee)

Comment 6

3 years ago
(In reply to Asa Dotzler [:asa] from comment #3)
> Also, is this the same as bug 1173145?

Ah, you're right and that bug has window and relevant discussion so lets pick this up there.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1173145
You need to log in before you can comment on or make changes to this bug.