[Settings] Going to homescreen settings from homescreen menu causes odd icon behaviour

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: RJ, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-exploratory-1], URL)

Attachments

(1 attachment)

74.68 KB, text/plain
Details
(Reporter)

Description

4 years ago
Created attachment 8530927 [details]
logcat

Description:
When user is going to homescreen settings from homescreen menu causes odd icon behaviour 

Repro Steps:
1) Update a Flame to 20141201040205
2) On homescreen tap a blanks space 
3) Tap homescreen settings


Actual:
Icon changes between two diffrent icons


Expected:
Icon stays the same 

Environmental Variables:
Device: Flame Master
Build ID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency:100%
See attached:logcat, video clip: https://www.youtube.com/watch?v=LfxCrcW5l3c
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
Issue is not affected on  2.1 flame and 2.0 flame 
Icon changes 

Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141126001202
Gaia: db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko: 211eae88f119
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Minor performance bug. Not nominating to block
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Duplicate of this bug: 1106737
Duplicate of this bug: 1126636
Issue reproduces on Flame 3.0

Icon layout dropdown appears as a button briefly when Homescreen settings is opened from Homescreen context menu

Device: Flame 3.0
Build ID: 20150312010235
Gaia: 0c4e8b0b330757e261b031b7e7f326ef419c9808
Gecko: 5334d2bead3e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.