Closed Bug 1106612 Opened 5 years ago Closed 5 years ago

[Music] Cannot play Forward Locked/DRM mp3 files

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED FIXED
2.2 S4 (23jan)
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: jlee, Assigned: squib)

References

()

Details

(Keywords: regression, Whiteboard: [2.2-exploratory-1])

Attachments

(2 files)

417.11 KB, text/plain
Details
46 bytes, text/x-github-pull-request
djf
: review+
Details | Review
Attached file DRM_logcat.txt
Description:
Music app does not load/play the forward locked/DRM audio files on memory card. Files do play in web player.
  
   
Repro Steps:
1) Update a Flame device to BuildID: 20141201040205
2) Go to the website http://210.55.198.68/aj/core/DRM/All_DRM/FL/
3) Find files FL_AUD_MP3_1.dm and FL_AUD.MP3_2.dm > Download mp3 files as Song
4) Go to Music app
5) Observe if DRM audio is in song list
  
Actual:
DRM/Forward Locked audio files on memory card are not loaded/played in Music app.
  
Expected: 
DRM/Forward Locked audio files on memory card are loaded/played in Music app.
  
Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  

  
Repro frequency: 100%
See attached: video clip (http://youtu.be/BLjLEa2K5r8), logcat (DRM_logcat.txt)
Issue does not occur on Flame 2.1 and Flame 2.0.

DRM/Forward Locked audio files on memory card are loaded/played in Music app.

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141126000203
Gaia: f9d6e3d83c3922e9399a6c27f5ce4cdd27bdfd05
Gecko: 45112935086f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
This is very similar to bug 1054953. Unsure of how important DRM files are. NI music owner to weigh in on a blocking decision for this bug.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(npark)
Need to confirm this with Hema on this as well, but I do not believe this is 2.2 blocker
Flags: needinfo?(npark) → needinfo?(hkoka)
I think this might be a regression from bug 1089718, but I'll need to figure out how to test this.
Blocks: 1089718
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attached file Fix it
David: Any ideas on how to write a unit test for this? Do I need a ForwardLock mock?
Attachment #8531766 - Flags: feedback?(dflanagan)
Comment on attachment 8531766 [details] [review]
Fix it

Upping to full review since this has unit tests now. I can add more tests if you think it's worthwhile (e.g. other formats, testing album art), but I'm not sure that gives us much in the way of extra coverage.
Attachment #8531766 - Flags: feedback?(dflanagan) → review?(dflanagan)
Attachment #8531766 - Flags: review?(dflanagan) → review+
Flags: needinfo?(hkoka)
Landed: https://github.com/mozilla-b2g/gaia/commit/ec74fa05386b6627c53f77466f97b66a7c2098f6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S4 (23jan)
You need to log in before you can comment on or make changes to this bug.