Closed Bug 1106663 (sms-groupmms) Opened 5 years ago Closed 3 years ago

[Messages][Meta] Make Group MMS work properly

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: julienw, Unassigned)

References

Details

(Keywords: foxfood, meta, Whiteboard: groupmms, foxfood)

No description provided.
Whiteboard: groupmms
Summary: [Messages] Make Group MMS work properly → [Messages][Meta] Make Group MMS work properly
Depends on: 1020209
Depends on: 1020893
Depends on: 875836
Depends on: 876483
Depends on: 880243
Depends on: 880251
Depends on: 880598
Duplicate of this bug: 1019421
Duplicate of this bug: 881213
Duplicate of this bug: 1018611
Here are the main issues we have here.

A. Technical issues
A1. bug 1020209: receiving group MMS doesn't work even if we enable it.
A2. bug 880251: on some SIMs, we don't know the MSISDN.

B. UX and Design issues
B1. bug 875836: display individual senders in group conversations. An existing design exists on this bug but it's now obsolete.
B2. (no bug) make it possible to choose between SMS or MMS when entering several recipients in the composer.
B3. (no bug) from a conversation thread, make it possible to answer to one person only (the sender, others?) instead of everyone. (likely linked to B1)

The other bugs are more dependencies of these issues.

NI Jenny to make you aware of this. I think we need UX spec more than VD spec for now, but we'll need VD spec later on.

Technical issues will be moved forward on the respective bugs.
Flags: needinfo?(jelee)
Regarding bug 880251, I wonder if we could try to make it work if we can know the MSISDN. We can know it if it's stored in the SIM or if we receive a MMS with 1 recipient only.

Jenny, maybe we can have a UX solution for this too: asking the user what his phone number is?
Another possibility: maybe when sending a group mms to several recipients including yourself, carriers automatically filters out the own phone number ? (just trying to think to all possibilities)

To be able to try this, we'll need to fix bug 1020209 first, and bug 1020893 will make it easier.
Another idea is, when receiving a MMS whose sender is included in receivers and we have the same text in the same conversation, we can know the phone number.
Hello Julien,

Regarding getting phone number from user, I've checked HTC's group message flow and I think it's good reference. Here's how it works:
1. Start a new message and enter several recipients. 
2. A check box with text "Send as individual message" is shown and checked by default.
3. Uncheck step 2 check box.
4. A dialog pops up that explains the fee situation for group message and asks user to input his phone number to enable group message. 
5. There's a "don't ask me again" check box for user to choose. 

My thoughts regarding each issue:
B1. I think this is a must for group message to work properly. 
B2. Hmmm I thought SMS/MMS is decided by if the message contains only text (and no subject) or not? Are you suggesting allowing user to send as "MMS" to multiple recipients even when there's only text?
B3. This would be relatively easy to do by using context menu (long press a message) if we can display individual sender.
 

With all the above being said, my point is UI-wise, it shouldn't be too hard to create a flow and display proper info to support group message. My concern is that, I don't really know any other platform that supports group message? which means even if we implement this feature, only Firefox OS users can benefit from it? If so, if this is something we should consider doing at this stage. Let me know, thanks =)
Flags: needinfo?(jelee)
(In reply to Jenny Lee (PTO 3/26-4/10) from comment #8)
> Hello Julien,
> 
> Regarding getting phone number from user, I've checked HTC's group message
> flow and I think it's good reference. Here's how it works:
> 1. Start a new message and enter several recipients. 
> 2. A check box with text "Send as individual message" is shown and checked
> by default.
> 3. Uncheck step 2 check box.
> 4. A dialog pops up that explains the fee situation for group message and
> asks user to input his phone number to enable group message. 
> 5. There's a "don't ask me again" check box for user to choose. 

So we found since then that we have a "Mobile ID" API that's used in Loop and that does steps 4-5 (including taking into account SIM changes and DSDS). I haven't tried it yet but because it's already existing its UX has likely been already reviewed. I think we should not do something new specific.

The best would be to try using it and see how it looks like.

> 
> My thoughts regarding each issue:
> B1. I think this is a must for group message to work properly. 

Agreed.

> B2. Hmmm I thought SMS/MMS is decided by if the message contains only text
> (and no subject) or not? Are you suggesting allowing user to send as "MMS"
> to multiple recipients even when there's only text?

Well, that's basically steps 2-3 from HTC :)

> B3. This would be relatively easy to do by using context menu (long press a
> message) if we can display individual sender.

Agreed.

Another possibility is being able to switch from Conversation view to Composer view so that the user can remove/add specific recipients. As discussed some time ago this would also be possible from a non-group Conversation view.

I think both possibilities make sense and could exist together :)

>  
> 
> With all the above being said, my point is UI-wise, it shouldn't be too hard
> to create a flow and display proper info to support group message. My
> concern is that, I don't really know any other platform that supports group
> message? which means even if we implement this feature, only Firefox OS
> users can benefit from it? If so, if this is something we should consider
> doing at this stage. Let me know, thanks =)

Well you described how HTC works... so I guess it's working in HTC phones?
Also this has been requested to me by several independent people so I think it works in some other platforms. I'll habe a look to see how it works in my old Android 4.1 :)
NI Jenny for previous comment and:

B1: should we ask Fang to update the visual design in bug 875836?
Flags: needinfo?(jelee)
(In reply to Julien Wajsberg [:julienw] (PTO May 1st) from comment #9)
> (In reply to Jenny Lee (PTO 3/26-4/10) from comment #8)
> > Hello Julien,
> > 
> > Regarding getting phone number from user, I've checked HTC's group message
> > flow and I think it's good reference. Here's how it works:
> > 1. Start a new message and enter several recipients. 
> > 2. A check box with text "Send as individual message" is shown and checked
> > by default.
> > 3. Uncheck step 2 check box.
> > 4. A dialog pops up that explains the fee situation for group message and
> > asks user to input his phone number to enable group message. 
> > 5. There's a "don't ask me again" check box for user to choose. 
> 
> So we found since then that we have a "Mobile ID" API that's used in Loop
> and that does steps 4-5 (including taking into account SIM changes and
> DSDS). I haven't tried it yet but because it's already existing its UX has
> likely been already reviewed. I think we should not do something new
> specific.
> 
> The best would be to try using it and see how it looks like.
> 

Hmm sure, where can I find this API and try it out?
 
> > B2. Hmmm I thought SMS/MMS is decided by if the message contains only text
> > (and no subject) or not? Are you suggesting allowing user to send as "MMS"
> > to multiple recipients even when there's only text?
> 
> Well, that's basically steps 2-3 from HTC :)

Yea haha, but it really doesn't make sense to me. What would be the reason of switching to MMS instead of SMS?

> 
> > B3. This would be relatively easy to do by using context menu (long press a
> > message) if we can display individual sender.
> 
> Agreed.
> 
> Another possibility is being able to switch from Conversation view to
> Composer view so that the user can remove/add specific recipients. As
> discussed some time ago this would also be possible from a non-group
> Conversation view.
> 
see last page of attachment 8533556 [details], seems like we should be able to apply the same behavior. 

> > With all the above being said, my point is UI-wise, it shouldn't be too hard
> > to create a flow and display proper info to support group message. My
> > concern is that, I don't really know any other platform that supports group
> > message? which means even if we implement this feature, only Firefox OS
> > users can benefit from it? If so, if this is something we should consider
> > doing at this stage. Let me know, thanks =)
> 
> Well you described how HTC works... so I guess it's working in HTC phones?
> Also this has been requested to me by several independent people so I think
> it works in some other platforms. I'll habe a look to see how it works in my
> old Android 4.1 :)

Personally, I would rather invest the time to do group chat over the Internet, you know like Firefox's own version of Whatsapp/Line or like iOS Message/gcaht etc. The trend is that fewer and fewer people are using traditional messaging, let alone group chatting which I imagine would cost essentially more.
Nevertheless, I will ask around and see what people think about this =)
Flags: needinfo?(jelee)
(In reply to Julien Wajsberg [:julienw] (PTO May 1st) from comment #10)
> NI Jenny for previous comment and:
> 
> B1: should we ask Fang to update the visual design in bug 875836?

I think it's still too early to involve visual, nothing's settled yet..but I will give her a heads up about this ;)
(In reply to Jenny Lee (PTO 3/26-4/10) from comment #11)
> (In reply to Julien Wajsberg [:julienw] (PTO May 1st) from comment #9)
> > (In reply to Jenny Lee (PTO 3/26-4/10) from comment #8)
> > > Hello Julien,
> > > 
> > > Regarding getting phone number from user, I've checked HTC's group message
> > > flow and I think it's good reference. Here's how it works:
> > > 1. Start a new message and enter several recipients. 
> > > 2. A check box with text "Send as individual message" is shown and checked
> > > by default.
> > > 3. Uncheck step 2 check box.
> > > 4. A dialog pops up that explains the fee situation for group message and
> > > asks user to input his phone number to enable group message. 
> > > 5. There's a "don't ask me again" check box for user to choose. 
> > 
> > So we found since then that we have a "Mobile ID" API that's used in Loop
> > and that does steps 4-5 (including taking into account SIM changes and
> > DSDS). I haven't tried it yet but because it's already existing its UX has
> > likely been already reviewed. I think we should not do something new
> > specific.
> > 
> > The best would be to try using it and see how it looks like.
> > 
> 
> Hmm sure, where can I find this API and try it out?

I think it's used in Loop if you can try it.
Of course you'll need a SIM without the MSISDN to try the whole UX flow :)

>  
> > > B2. Hmmm I thought SMS/MMS is decided by if the message contains only text
> > > (and no subject) or not? Are you suggesting allowing user to send as "MMS"
> > > to multiple recipients even when there's only text?
> > 
> > Well, that's basically steps 2-3 from HTC :)
> 
> Yea haha, but it really doesn't make sense to me. What would be the reason
> of switching to MMS instead of SMS?

Because that's the only way to have group MMS :)
With SMS we can only send individual messages... So the recipients don't know this is a group conversations and can't answer to the group.

> 
> > 
> > > B3. This would be relatively easy to do by using context menu (long press a
> > > message) if we can display individual sender.
> > 
> > Agreed.
> > 
> > Another possibility is being able to switch from Conversation view to
> > Composer view so that the user can remove/add specific recipients. As
> > discussed some time ago this would also be possible from a non-group
> > Conversation view.
> > 
> see last page of attachment 8533556 [details], seems like we should be able
> to apply the same behavior. 

Agreed :)

> 
> > > With all the above being said, my point is UI-wise, it shouldn't be too hard
> > > to create a flow and display proper info to support group message. My
> > > concern is that, I don't really know any other platform that supports group
> > > message? which means even if we implement this feature, only Firefox OS
> > > users can benefit from it? If so, if this is something we should consider
> > > doing at this stage. Let me know, thanks =)
> > 
> > Well you described how HTC works... so I guess it's working in HTC phones?
> > Also this has been requested to me by several independent people so I think
> > it works in some other platforms. I'll habe a look to see how it works in my
> > old Android 4.1 :)
> 
> Personally, I would rather invest the time to do group chat over the
> Internet, you know like Firefox's own version of Whatsapp/Line or like iOS
> Message/gcaht etc. The trend is that fewer and fewer people are using
> traditional messaging,

That's the case in some countries, but is it the case in all countries ?
Also this is cross-platform, works cross-devices, and even works with phones that don't really support group MMS -- they just look like normal MMS.

This is really the contrary to whatsapp-like conversation which is not standard based and needs a dedicated app.

Moreover the technical support is nearly ready -- I could imagine the UI would be essentially the same for group MMS than for what you propose, so I think the work could be fairly reused anyway.

> let alone group chatting which I imagine would cost
> essentially more.

Actually I don't think it costs more with group MMS -- because the user still sends one MMS only.

> Nevertheless, I will ask around and see what people think about this =)

FTR I got at least 2 people that go through the trouble of filing a bug on bugzilla just for group MMS.
Duplicate of this bug: 1174441
Whiteboard: groupmms → groupmms, foxfood
Depends on: 1183074
As a data point, I checked on a blackberry, and they don't actually remove the "current user" when replying to all, if the MSISDN is missing. So maybe we should not focus on this issue and just make it work for a start...
Depends on: 918516
> > Nevertheless, I will ask around and see what people think about this =)
> 
> FTR I got at least 2 people that go through the trouble of filing a bug on
> bugzilla just for group MMS.

FWIW, I was about to file a bug for "Group MMS doesn't work" when I discovered this bug, and I need this feature to land soon if I'm going to continue to use a Firefox OS device as my primary device.
(Adding the Foxfood keyword so this shows up on http://foxfooding.github.io/dashboard/)
Keywords: foxfood
Tim, I'm sorry to say this won't land soon for sure, there is a lot of work to be done and it's not a high priority right now. (I'm not deciding priority, otherwise it would be higher for sure)
Depends on: 1226866
Depends on: 1239714
Julien,
saw you mention this bug here :- https://wiki.mozilla.org/Community:SummerOfCode16:Brainstorming
Could you tell me a bit more about it? Where could I start?
Flags: needinfo?(felash)
You can start looking at this bug dependencies ;)
Flags: needinfo?(felash)
Julien,
Fixed the first dependency :) Which would be a good next one? Unable to choose. Also, you mentioned marionette tests. Is that a part of this bug as well?
Flags: needinfo?(felash)
Hey Kalpesh,
Planning for MMS bugs is going from long time. As you can see in these bugs, there is lots of discussion and it's very old too. So, i will suggest to go through these discussion first and ni? julienw for latest ui/ux Or whatever final thing is. 

In General, Yes tests (integration/unit) are important, so i guess these bugs involve test too. But you will get clear while working on bug :) 

you can start with Bug 880251 or Bug Bug 875836 , as it doesn't seem too complex (it's only my personal suggestion, you can pick which ever you want :) )

You can wait for julien's reply for more clarification :) 

Thanks
1. In Gecko, bug 1020209 and bug 1020893 are important. Bug 1020209 should fix the feature at all in gecko (when we enable it, it will be disabled at first), and bug 1020893 will make it possible for a user to enable it experimentally using a pref and the Settings app.

2. In Gaia, bug 875836 is the most important: in one group mms thread, it will allow to see easily who sent which messages.
Flags: needinfo?(felash)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.